Loop triggers startup terminal/error-console spew about "Exception running bootstrap method", "Component is not available", "Custom widget with id loop-button"

RESOLVED DUPLICATE of bug 1229471

Status

Hello (Loop)
Client
RESOLVED DUPLICATE of bug 1229471
3 years ago
3 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
STR:
 1. Start Firefox Nightly with a fresh profile.
 2. Open Browser Console (Ctrl shift J) and scroll to the top, or look at the terminal where you started Firefox from.

ACTUAL RESULTS: These errors appear in the browser console:
{
addons.xpi	WARN	Exception running bootstrap method startup on loop@mozilla.org: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIStyleSheetService.loadAndRegisterSheet]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///tmp/tmpGqMLmC/firefox/browser/features/loop@mozilla.org.xpi!/bootstrap.js :: startup :: line 794"  data: no] Stack trace: startup()@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///tmp/tmpGqMLmC/firefox/browser/features/loop@mozilla.org.xpi!/bootstrap.js:794 < XPI_callBootstrapMethod()@resource://gre/modules/addons/XPIProvider.jsm:4591 < XPI_startup()@resource://gre/modules/addons/XPIProvider.jsm:2719 < callProvider()@resource://gre/modules/AddonManager.jsm:224 < _startProvider()@resource://gre/modules/AddonManager.jsm:832 < AMI_startup()@resource://gre/modules/AddonManager.jsm:1012 < AMP_startup()@resource://gre/modules/AddonManager.jsm:2793 < AMC_observe()@resource://gre/components/addonManager.js:58

While creating services from category 'profile-after-change', service for entry 'SpeechDispatcher Speech Synth', contract ID '@mozilla.org/synthspeechdispatcher;1' does not implement nsIObserver.

[Exception... "Component is not available"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///tmp/tmpGqMLmC/firefox/browser/features/loop@mozilla.org.xpi!/bootstrap.js :: createLoopButton/<.onBuild :: line 705"  data: no]

[CustomizableUI] Custom widget with id loop-button does not return a valid node
}

The first and last error appear in my terminal, too.

Regression range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c2cefe6f9f0a0218a159cefb1880ebaf88fb0f1c&tochange=5a8a532f97cd82b06b2f45515b633958bda50c8e

Looks like a regression from bug 1223573.
(Reporter)

Comment 1

3 years ago
I'm using latest Firefox Nightly (2015-12-01) on 64-bit Ubuntu 15.10, btw.

Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Flags: needinfo?(standard8)
(Reporter)

Comment 2

3 years ago
(Ignore the "synthspeechdispatcher" error in comment 0 -- that predated this bug and seems to be unrelated. I'll file that separately.)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(standard8)
Resolution: --- → DUPLICATE
Duplicate of bug: 1229471
You need to log in before you can comment on or make changes to this bug.