Support for apple-touch-icon-precomposed to trigger mozbrowsericonchange

RESOLVED FIXED in Firefox 46

Status

()

Core
DOM: Events
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jedireza, Assigned: sfoster)

Tracking

unspecified
mozilla46
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox46 fixed)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment, 1 obsolete attachment)

Comment hidden (empty)
(Assignee)

Comment 1

2 years ago
AFAICT this looks like it just needs a simple change to https://dxr.mozilla.org/mozilla-central/source/dom/browser-element/BrowserElementChildPreload.js#597 and the associated mochitest to recognize the rel="apple-touch-icon-precomposed" value as a change we want to announce as a mozbrowsericonchange event
(Assignee)

Updated

2 years ago
Assignee: nobody → sfoster
(Assignee)

Comment 2

2 years ago
Created attachment 8695639 [details] [diff] [review]
rel=apple-touch-icon-precomposed should fire mozbrowsericonchange
(Assignee)

Comment 3

2 years ago
Created attachment 8695641 [details] [diff] [review]
rel=apple-touch-icon-precomposed should fire mozbrowsericonchange
Attachment #8695641 - Flags: review?(fabrice)
(Assignee)

Updated

2 years ago
Attachment #8695639 - Attachment is obsolete: true
(Assignee)

Comment 4

2 years ago
Comment on attachment 8695641 [details] [diff] [review]
rel=apple-touch-icon-precomposed should fire mozbrowsericonchange

This fixes the symptoms of bug 1217095 for me - github and others are using the 'apple-touch-icon-precomposed' in favor of the apple-touch-icon link relation. 

We may also need a corresponding gaia change to update the condition that triggers the warning added in https://github.com/mozilla-b2g/gaia/commit/f3a33a528d194dc631ecc892ba24ea152ed087b4
Whiteboard: [systemsfe]
Attachment #8695641 - Flags: review?(fabrice) → review+
(Assignee)

Comment 5

2 years ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=27b46d0716eb
(Assignee)

Comment 6

2 years ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=41dc498b776c
(Assignee)

Comment 7

2 years ago
(In reply to Sam Foster [:sfoster] from comment #6)
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=41dc498b776c

Still some orange in there, what do you think Fabrice? Sorry I have no context on these tests so I'm relying on someone else to tell me if I caused a problem here or not.
Flags: needinfo?(fabrice)
I can't see any reasons for these failures to be caused by your patch. ship it!
Flags: needinfo?(fabrice)
(Assignee)

Comment 9

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/8e8934c580ec5c0c7fcc60543cfcda621cfef87b
Bug 1229838 - rel=apple-touch-icon-precomposed should fire mozbrowsericonchange. r=fabrice

Comment 10

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/8e8934c580ec
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox46: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
(Assignee)

Updated

2 years ago
Blocks: 1232710
You need to log in before you can comment on or make changes to this bug.