Closed Bug 1229975 Opened 4 years ago Closed 4 years ago

[Skia-update branch] GrConvexPolyEffect.cpp:260: failed assertion "SkPathPriv::CheapComputeFirstDirection(path, &dir)"

Categories

(Core :: Graphics, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla48
Tracking Status
firefox45 --- affected
firefox48 --- fixed

People

(Reporter: jruderman, Assigned: lsalzman)

References

(Blocks 1 open bug)

Details

(Keywords: regression, testcase, Whiteboard: [gfx-noted])

Attachments

(3 files)

Attached file testcase
Using the Mac build from https://treeherder.mozilla.org/#/jobs?repo=try&revision=91dc4f334fc5

(This does NOT reproduce on mozilla-central because bug 1082598 has not landed yet.)

gfx/skia/skia/src/gpu/effects/GrConvexPolyEffect.cpp:260: failed assertion "SkPathPriv::CheapComputeFirstDirection(path, &dir)"
Attached file stack
Filed upstream bug report: https://bugs.chromium.org/p/skia/issues/detail?id=4727
Whiteboard: [gfx-noted]
Parking with Lee to await the patch.
Assignee: nobody → lsalzman
(In reply to Milan Sreckovic [:milan] from comment #3)
> Parking with Lee to await the patch.

No movement upstream on this issue yet - trying to bump it.
This is just a straight backport of the upstream fix here: https://skia.googlesource.com/skia.git/+/7888de0db74ac08162c85903a71a48f6d2a3013f
Attachment #8735988 - Flags: review?(mchang)
Attachment #8735988 - Flags: review?(mchang) → review+
https://hg.mozilla.org/mozilla-central/rev/2b5a3e10e396
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
You need to log in before you can comment on or make changes to this bug.