Closed Bug 123004 Opened 18 years ago Closed 18 years ago

Browser won't submit the form without a file being selected

Categories

(SeaMonkey :: UI Design, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 116210

People

(Reporter: cacarp, Assigned: trudelle)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122108

This page is multiform so you have to search for a file before you can see the
form with the problem.  I'm using a form to allow visitors to upload a file if
they wish to replace the existing file.  The file upload is optional but the
other data is not.  Mozilla will not allow the form to be submitted without a
file selected.  Clicking the submit button does nothing.  I tried the page on
other browsers and it works fine.

Reproducible: Always
Steps to Reproduce:
1.Go to the URL (http://profit2.tamu.edu/photolibrary/modify.php)
2.enter 'l' in the search box and click search
3.pick any photo that shows up (radio button on the left side) and submit
4.try to submit the following form without choosing a file on the upload

Actual Results:  Nothing

Expected Results:  Sent the form for processing

This is also problem for the Windows version of Mozilla.  I've been looking for
some kind of work around but haven't found one yet.
Build ID: 2002 01 30 03. Windows 2000.

WMF, i.e. I'm brought to a page which is blank
except for the text "Back to the PhotoLibrary".

Reporter: Do you have the possibility to try a later build,
the one you used is more than one month old...
dup of bug #116210 (announced in 0.9.7 releases notes).
Agreed, dupe of 116210

*** This bug has been marked as a duplicate of 116210 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.