don't let Alert messages keep focus off browser window

VERIFIED DUPLICATE of bug 59314

Status

()

--
enhancement
VERIFIED DUPLICATE of bug 59314
17 years ago
11 years ago

People

(Reporter: matevz.jekovec, Assigned: trudelle)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.8+) Gecko/20020130
BuildID:    20020130

Ok guys, IE's weak point: If there a message appears, you're stuck until you hit
the ok button. BUT, what if there are *150* messages followed one by another.
Pretty annoying. However, you're stuck in MoZilla as well, so you can't close
the window, until you click all the 150 messages. Can this be fixed? (It's
probably hardcoded with parent/child OS code, but I think we should override
this somehow)
Check this:
http://www.netlaughter.com/haha.htm
, and advice me, how to knock this thingy down?


Reproducible: Always
Steps to Reproduce:
.

Actual Results:  You can't close the window, if a message appears. If there is
unlimited number of messages following one by another, you're stuck!

Expected Results:  You should close the window if neccesary, despite the message
showing or annoying you sometimes.

Comment 1

17 years ago
Old Summary: How can I get rid of annoying messages!?
New Summary: don't let Alert messages keep focus off browser window

Changing component from XP Apps to Event Handling. (I think that's right.)

Leaving unconfirmed at this time, because I can't tell if there is a duplicate
of this bug.

Have to agree that that web page is *annoying*. 

Actual behavior: Alert messages can steal focus from browser.

Expected behavior: Alert messages cannot steal the focus.
Component: XP Apps → Event Handling
Summary: How can I get rid of annoying messages!? → don't let Alert messages keep focus off browser window

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 59314 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.