Closed Bug 1230098 Opened 9 years ago Closed 8 years ago

[Skia-update branch] SkScan_AntiPath.cpp:230: failed assertion "start >= 0 && stop > start"

Categories

(Core :: Graphics, defect)

46 Branch
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox45 --- affected

People

(Reporter: jruderman, Assigned: milan, NeedInfo)

References

Details

(Keywords: assertion, regression, testcase, Whiteboard: [gfx-noted])

Attachments

(2 files)

Attached file testcase
Using the Mac build from https://treeherder.mozilla.org/#/jobs?repo=try&revision=91dc4f334fc5

(This does NOT reproduce on mozilla-central because bug 1082598 has not landed yet.)

gfx/skia/skia/src/core/SkScan_AntiPath.cpp:230: failed assertion "start >= 0 && stop > start"
Attached file stack
I wasn't able to reproduce this one. We should investigate this again after the Skia update lands to check if it has been fixed upstream.
Whiteboard: [gfx-noted]
Jesse: does this still reproduce after the Skia update?
Flags: needinfo?(jruderman)
I can't reproduce on OS X 10.11.2; Jesse's assert seems to have been on OS X, but not sure what version.  Could be fixed, or could be intermittent, or could be OS X or hardware specific.
Assignee: nobody → milan
(In reply to Milan Sreckovic [:milan] from comment #4)
> I can't reproduce on OS X 10.11.2; Jesse's assert seems to have been on OS
> X, but not sure what version.  Could be fixed, or could be intermittent, or
> could be OS X or hardware specific.

I still am not able to reproduce this either. We'd need Jesse to check on this one to see if it is an issue.
Let's reopen if we can reproduce.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Version: Trunk → 46 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: