If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

incident id for taskgraph id BgxXGUAjQqmJ_VOFSSGYtw

RESOLVED FIXED

Status

Taskcluster
Scheduler
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: kmoir, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
not sure if this is the correct bucket but dustin asked me to open a bug

https://tools.taskcluster.net/task-graph-inspector/#BgxXGUAjQqmJ_VOFSSGYtw/

dustin	    Dec 03 09:46:23 taskcluster-scheduler app/web.4: Thu, 03 Dec 2015 17:46:23 GMT base:api Error occurred handling: /task-graph/BgxXGUAjQqmJ_VOFSSGYtw/inspect, err: [object Object], as JSON: {"statusCode":404,"code":"ResourceNotFound","body":{"code":"ResourceNotFound","message":{"lang":"en-US","value":"The specified resource does not
	dustin	exist.\nRequestId:e2d3884f-0002-002f-0cf2-2d7e30000000\nTime:2015-12-03T17:46:23.5415880Z"}},"retriesMade":0}, incidentId: 0384e749-b93e-4974-817b-27ce0f9a1372 undefined 
	kmoir	right I don't see it in our papertrailhttps://tools.taskcluster.net/auth/roles
	dustin	kmoir: I'm guessing one of the tasks in that graph doesn't exist
	kmoir	dustin: hmm okay
	dustin	kmoir: I'm guessing it's one of these two calls getting the 404 - https://github.com/taskcluster/task-graph-scheduler/blob/master/routes/api/v1.js#L535
		dustin	kmoir: can you file a bug?  This is something we should handle better, at least
	dustin	it looks like something is missing from teh Azure tables
	kmoir	dustin: sure
I've been having trouble with task-graph inspection, too
	dustin	I wonder if something's funky in Azure
	dustin	although the status page is all green checkmarks
(Reporter)

Updated

2 years ago
Blocks: 1215204
Sorry, I thought you guys figured it out in channel. I'll take a look tomorrow.
Flags: needinfo?(jopsen)
Component: General → Scheduler
I've noticed that:

1) if we provide a non-existing (randomly generated) TaskGraphId we also get a 500, rather than a 404
2) heroku is 3 non-merge commits behind github taskcluster master branch:

> pmoore@Petes-iMac:~/git/task-graph-scheduler master $ git fetch mozilla; git fetch heroku; git log --pretty=oneline heroku/master..mozilla/master
> e541b824956e5c29228057b3b1615ca423ef3954 Merge pull request #19 from djmitche/docs-clarification-createTask-scopes
> 22d109c2dac5a5bac25af5ba98689fe40dd5bdfa clarify scopes required in a graph
> eb66604768fddd93ba60c9d6977c7c06e002d967 Merge pull request #18 from djmitche/typo
> 3d3feb5514f42034ca3662adf253d368f7801577 Add missing space on line continuation
> e4a1c5b5d17d158867f49928b728337092116722 Merge pull request #17 from petemoore/master
> da24cf751a753725038f6f843c11ad2403d96f2d trivial doc fix
> pmoore@Petes-iMac:~/git/task-graph-scheduler master $

@Jonas, when you look at this later today, independently from Kim's issue, can you add a test that a 404 is returned for a non-existing TaskGraphId? Our CI looks green for the current production revision, so I don't think we have a working test for it: https://travis-ci.org/taskcluster/task-graph-scheduler/builds/87780042.

Of course, this may not be the cause in this case.

Independently, I'm manually pushing to heroku now so we have the latest github taskcluster master version deployed (e541b824956e5c29228057b3b1615ca423ef3954)...

In Orlando we can discuss if we want to deploy from github master branch instead...

Thanks!
Note, pushing to heroku (from 9509bab6ee41c7bfda349dce2e9fff4cadee143d -> e541b824956e5c29228057b3b1615ca423ef3954) didn't fix either issue (Kim's HTTP 500 or the HTTP 500 for a fake task graph id that should be an HTTP 404)...
@pmoore, Nice catch... I think this was reported in bug 1188520
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Depends on: 1188520
Flags: needinfo?(jopsen)
Resolution: --- → FIXED
@kmoir,
I think it's safe to say that the task-graph you were looking up was never submitted successfully.
At least that would explain it... But with task-graph-scheduler there could be other bugs, as it's sort of old and not getting a lot of attention because it's on its way out (in exchange for a very similar thing - don't worry the old API will stick around for compatibility).
You need to log in before you can comment on or make changes to this bug.