Stolen WebGL canvas trips "Assertion failure: !mActor || mActor->mDestroyed (Cannot use a texture on several IPC channels.)"

RESOLVED DUPLICATE of bug 1250954

Status

()

Core
Graphics: Layers
--
critical
RESOLVED DUPLICATE of bug 1250954
2 years ago
2 years ago

People

(Reporter: Jesse Ruderman, Assigned: jerry)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Trunk
Unspecified
Windows 10
assertion, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox45 affected)

Details

(Whiteboard: [gfx-noted])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8695613 [details]
testcase

Assertion failure: !mActor || mActor->mDestroyed (Cannot use a texture on several IPC channels.), at gfx/layers/client/TextureClient.cpp:652
(Reporter)

Comment 1

2 years ago
Created attachment 8695617 [details]
stack
Attempted to reproduce on Linux, but could not trigger the issue. :mchang tried to reproduce it on OS X, but it also failed to trigger there as well. Is this still occurring in nightly for you?
Flags: needinfo?(jruderman)
OS: Unspecified → Mac OS X
Whiteboard: [gfx-noted]
I can reproduce the crash at win10.
Assignee: nobody → hshih
Status: NEW → ASSIGNED
Flags: needinfo?(jruderman)
OS: Mac OS X → Windows 10
With the bug 1250954 fix, I don't hit the crash now.

Jesse, please reopen this bug if there still has crash.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(jruderman)
Resolution: --- → DUPLICATE
Duplicate of bug: 1250954
(Assignee)

Updated

2 years ago
Flags: needinfo?(jruderman)
You need to log in before you can comment on or make changes to this bug.