Closed Bug 1230425 Opened 4 years ago Closed 3 years ago

Assertion failure: mFrame->Combines3DTransformWithAncestors() || IsTransformSeparator()

Categories

(Core :: Layout, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox45 --- affected
firefox52 --- fixed

People

(Reporter: jruderman, Assigned: sinker)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, testcase)

Attachments

(3 files, 1 obsolete file)

Attached image testcase
Assertion failure: mFrame->Combines3DTransformWithAncestors() || IsTransformSeparator(), at layout/base/nsDisplayList.h:4006
Attached file stack
I suspect either Matt or Thinker would know about this.
Flags: needinfo?(tlee)
Flags: needinfo?(matt.woodrow)
I already has a fix at another bug.  I would move the patch to here.
Flags: needinfo?(tlee)
Assignee: nobody → tlee
Flags: needinfo?(matt.woodrow)
Attached patch WIP.diff (obsolete) — Splinter Review
Matt, |BuildDisplayListForStackingContext()| decides if to install a transform item according the value of |IsTransformed()|.  |Combines3DTransformWithAncestors()| also checks if the frame is transformed, but in a bit different way.  The difference makes them inconsistent.

My idea is to call |IsTransformed()| in |Combines3DTransformWithAncestors()| instead of doing test by itself.  How do you think?
Attachment #8809251 - Flags: feedback?(matt.woodrow)
(In reply to Thinker Li [:sinker] from comment #4)
> Created attachment 8809251 [details] [diff] [review]
> WIP.diff
> 
> Matt, |BuildDisplayListForStackingContext()| decides if to install a
> transform item according the value of |IsTransformed()|. 
> |Combines3DTransformWithAncestors()| also checks if the frame is
> transformed, but in a bit different way.  The difference makes them
> inconsistent.
> 
> My idea is to call |IsTransformed()| in |Combines3DTransformWithAncestors()|
> instead of doing test by itself.  How do you think?

This sounds good, but it's different what's in the attached patch.
Attachment #8809251 - Attachment is obsolete: true
Attachment #8809251 - Flags: feedback?(matt.woodrow)
Attachment #8809375 - Flags: review?(matt.woodrow)
Attachment #8809375 - Flags: review?(matt.woodrow) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0c62b9c32517
Fix the test of transform of Combines3DTransformWithAncestors. r=mattwoodrow
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/0c62b9c32517
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Duplicate of this bug: 1312363
You need to log in before you can comment on or make changes to this bug.