test_add_to_an_existing_contact_from_messages.py : TimeoutException: TimeoutException: Timed out after 307.0 seconds

RESOLVED DUPLICATE of bug 1223499

Status

RESOLVED DUPLICATE of bug 1223499
3 years ago
3 years ago

People

(Reporter: MaxIvanov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Description: Test case fails with "ScriptTimeoutException"

Steps:
1. Update a flame device to 20151204030224

2. Run this test case http://lxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/tests/functional/messages/test_add_to_an_existing_contact_from_messages.py

Actual result:
"ScriptTimeoutException"

Expected result:
Test completes successfully.

Repro Rate: Reproduced via Jenkins adhoc (0/5 passing)
http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc.bitbar/362/HTML_Report/

Traceback (most recent call last):
File "/var/lib/jenkins/jobs/flame-kk-512.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_client-2.0.0-py2.7.egg/marionette/marionette_test.py", line 325, in run
self.setUp()
File "/var/lib/jenkins/jobs/flame-kk-512.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/tests/functional/messages/test_add_to_an_existing_contact_from_messages.py", line 23, in setUp
self.data_layer.send_sms(self.environment.phone_numbers[0], _text_message_content)
File "/var/lib/jenkins/jobs/flame-kk-512.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 532, in send_sms
result = self.marionette.execute_async_script('return GaiaDataLayer.sendSMS(%s, %s, %s)' % (number, message, str(skip_verification).lower()))
File "/var/lib/jenkins/jobs/flame-kk-512.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-1.1.1-py2.7.egg/marionette_driver/marionette.py", line 1731, in execute_async_script
rv = self._send_message("executeAsyncScript", body, key="value")
File "/var/lib/jenkins/jobs/flame-kk-512.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-1.1.1-py2.7.egg/marionette_driver/decorators.py", line 36, in _
return func(*args, **kwargs)
File "/var/lib/jenkins/jobs/flame-kk-512.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-1.1.1-py2.7.egg/marionette_driver/marionette.py", line 741, in _send_message
    self._handle_error(err)
  File "/var/lib/jenkins/jobs/flame-kk-512.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-1.1.1-py2.7.egg/marionette_driver/marionette.py", line 802, in _handle_error
    raise errors.lookup(error)(message, stacktrace=stacktrace)
ScriptTimeoutException: ScriptTimeoutException: timed out
(Reporter)

Comment 1

3 years ago
Corrections, the correct traceback is:

Traceback (most recent call last):
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_client-2.0.0-py2.7.egg/marionette/marionette_test.py", line 344, in run
testMethod()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/tests/functional/messages/test_add_to_an_existing_contact_from_messages.py", line 32, in test_sms_add_number_to_existing_contact
self.message_thread.wait_for_received_messages()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/apps/messages/regions/message_thread.py", line 25, in wait_for_received_messages
*self._received_message_content_locator))))
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-1.1.1-py2.7.egg/marionette_driver/wait.py", line 143, in until
cause=last_exc)
TimeoutException: TimeoutException: Timed out after 307.0 seconds
(Reporter)

Updated

3 years ago
Summary: test_add_to_an_existing_contact_from_messages.py : ScriptTimeoutException: ScriptTimeoutException: timed out → test_add_to_an_existing_contact_from_messages.py : TimeoutException: TimeoutException: Timed out after 307.0 seconds
(Reporter)

Comment 2

3 years ago
Just figured out that is the same as Bug 1223499
(In reply to Max Ivanov[:MaxIvanov] from comment #2)
> Just figured out that is the same as Bug 1223499

So it's a duplicate then, right?
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1223499
You need to log in before you can comment on or make changes to this bug.