EXCEPTION_ACCESS_VIOLATION_READ crashes in nsDisplayList::HitTest, starting in nightly 20151127030231

RESOLVED DUPLICATE of bug 1230075

Status

()

Core
Layout: View Rendering
--
critical
RESOLVED DUPLICATE of bug 1230075
2 years ago
2 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

({crash, regression, topcrash})

Trunk
x86
Windows NT
crash, regression, topcrash
Points:
---

Firefox Tracking Flags

(firefox42 unaffected, firefox43 unaffected, firefox44 unaffected, firefox45- fixed)

Details

(crash signature)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-20c02353-9114-439d-9d8d-a347b2151128.
=============================================================

There has long been a low baseline of EXCEPTION_BREAKPOINT crashes in nsDisplayList::HitTest.

However, there's clearly a new crash that appeared on Windows, starting in nightly 20151127030231, of EXCEPTION_ACCESS_VIOLATION_READ crashes in nsDisplayList::HitTest.

A search for all such crashes on the nightly channel since August is here:
https://crash-stats.mozilla.com/signature/?product=Firefox&release_channel=nightly&date=%3E%3D2015-08-01&reason=EXCEPTION_ACCESS_VIOLATION_READ&signature=nsDisplayList%3A%3AHitTest&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&page=1#aggregations
(Reporter)

Comment 1

2 years ago
The regression range for that nightly relative to the previous one is:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c321d8403851&tochange=47b49b0d3236
(Reporter)

Comment 2

2 years ago
Most likely guess is a regression from bug 1168263, causing a crash in code introduced only a week before in https://hg.mozilla.org/mozilla-central/rev/ac7d0d74ced6 .
Blocks: 1168263
Flags: needinfo?(tlee)
Flags: needinfo?(matt.woodrow)
Flags: needinfo?(botond)
This should be fixed by bug 1230075.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(tlee)
Flags: needinfo?(matt.woodrow)
Flags: needinfo?(botond)
Resolution: --- → DUPLICATE
Duplicate of bug: 1230075
status-firefox45: affected → fixed
tracking-firefox45: ? → -
You need to log in before you can comment on or make changes to this bug.