bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Macbook Pro 13', 2015 El Capitan, overheats when YouTube video is playing

RESOLVED INVALID

Status

()

Firefox
Untriaged
--
major
RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: ya.public0, Unassigned)

Tracking

45 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: El Capitan 10.11 overheats)

Attachments

(8 attachments)

(Reporter)

Description

3 years ago
Created attachment 8696296 [details]
2015-12-06 02-04-32 YouTube.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20151205030208

Steps to reproduce:

Macbook Pro 13' Early 2015, i7, 16Gb, Iris 6100 1536 Mb, OS X El Capitan 10.11.2 Beta (15C48a)
I tried in Firefox Nightly 45.01a (2015-12-05) and FirefoxDeveloperEdition 44.0a2 (2015-12-05) and Firefox 42. In all I have this problem.

Open some video on YouTube.com 


Actual results:

CPU Core 1 & CPU Core 2 temperature raises to 100C and CPU Gtx Core raises to 104C!


Expected results:

When open the same video in Safari Version 9.0.2 (11601.3.9) the temperature of all cores under 60C.
(Reporter)

Updated

3 years ago
Severity: normal → major
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
Whiteboard: El Capitan 10.11 overheats
Please check if the issue occurs using Firefox in safe mode (with your addons disabled):
http://support.mozilla.com/kb/Safe+Mode

And on a new, empty profile:
http://support.mozilla.org/en-US/kb/Managing-profiles#w_starting-the-profile-manager
Flags: needinfo?(ya.public0)
(Reporter)

Comment 2

3 years ago
Check in Firefox and FirefoxDeveloperEdition in safe mede and with new test profile.

The issue occurred as in previous time, but not so bad.

Suspicion fell on Adguard(https://adguard.com/ru/welcome.html), but I turned it off, and nothing changed.

CPU and GPU temperature (the safe mode) is rising slightly slower, but it touches on 100C as before.

In Firefox and FirefoxDE video (https://www.youtube.com/watch?v=PMFHQXxqYOg) in safe mode warm up my Mac to 85-100C in window mode and 100-105C in fullscreen mode.

In Safari the same video plays in both window and fullscreen modes in 55-65C.
Flags: needinfo?(ya.public0)
(Reporter)

Comment 3

3 years ago
Created attachment 8696777 [details]
2015-12-08 22-24-32 KUNG FU PANDA 3 Trailer #2 | Movie 2016 - YouTube.png

FirefoxDE in safe mode with new test profile. Full screen.
CPU GFx Core 105C!
CPU Cores 96-97C
(Reporter)

Comment 4

3 years ago
Created attachment 8696782 [details]
2015-12-08 22-23-02 Activity Monitor (All Processes).png

FirefoxDE in safe mode and with new test profile. Window mode.
CPU Gfx Core 104C!
CPU Cores 92-93C!
(Reporter)

Comment 5

3 years ago
Created attachment 8696784 [details]
2015-12-08 22-19-13.png

Safari full screen mode. CPU, CPU Gfx 61-63C!
(Reporter)

Comment 6

3 years ago
Created attachment 8696786 [details]
2015-12-08 22-16-36 Activity Monitor (All Processes).png

Safari window screen mode. CPU, CPU Gfx 60-61C!
Can you open about:config and set layers.acceleration.draw-fps to true. This should add a pink counter to the top left. What is the left most number when you're playing videos on Youtube?
Flags: needinfo?(ya.public0)
(Reporter)

Comment 8

3 years ago
FirefoxDE 44.02a. I set layers.acceleration.draw-fps to true. The left most number is 60.
Flags: needinfo?(ya.public0)
(Reporter)

Comment 9

3 years ago
Maybe it's not a bug, but a feature? The most powerful MacBook Pro 13' 2015 with i7(3.1-3.4GHz) heats in Xcode compilation as "well" as when plays video in youtube. And now I want turn off the hyperthreading permanently for reducing the heat emission.
But at same time Safari plays video in fullscreen at 63C of CPU. And I want to help to figure out why the FF acts in a different way.
(Reporter)

Comment 10

3 years ago
Mac OS X EL Capitan - System Version: OS X 10.11.2 (15C50), maybe it does matter.

Comment 11

3 years ago
i confirmed this issue "overheating" in my MacBook Pro 13' late 2013 with i5(2.4 GHz) and OS X 10.11.2 (15C50)
i played KUNG FU PANDA 3 Trailer #2 | Movie 2016 - YouTube 480  at full screen in Safari but the temperature of CPU didn't rise and was stable from the begining to end of trailer abroximatly 50 °C.
but with Firefox 45.0a2 (2016-01-13) it rised from the 50°C  to 70°C.
Hi guys,

I just got an MacBook Pro to test this on my end and to be honest, I could not reproduce it. I have installed a free trial application for CPU temperature and observed both the measurement and activity monitor while playing the "Kung fu panda 3 trailer #2" in 1080p in full screen. The iStat application you were using is not reading right on my end. Anything I do, the temperature displayed is always 36C.

- On Firefox 43.0.4 (latest release) the CPU usage spiked right when the movie started to play, but after it stabilized somewhere around 35%, and the temperature raised from 45C in idle to about 55C as seen in my screenshot.
- On Nightly 46.0a1-20160119030232 the CPU spiked the same at start but stabilized at almost the same value while playing, and the temperature raised to 57C while playing.
- On Safari 9.0.2 the temperature raised around 51-53C while video play. A 2 to 4 degrees difference in my opinion is normal between Safari and Firefox since Safari is the native browser and it was optimized especially for Mac OS.  

I never encountered temperatures more than 60C while playing videos on the current configuration and that was a spike not a stable value. I used a MacBook Pro retina 13" from early 2015 with i5-2,7Ghz processor, 8 GB of RAM, Intel Iris Graphics 6100 and Mac OS X 10.11.2.
All the tests were made on a freshly installed OS, with new profile and no custom settings made on about:config page.

Can you guys please retest this on latest Firefox release, latest Nightly build (https://nightly.mozilla.org/) and report back the results ? Maybe the problem was fixed in the latest versions or maybe there is something from your end that is causing this.

Thanks,
Paul
Flags: needinfo?(ya.public0)
Created attachment 8709995 [details]
Nightly vs Firefox.png
(Reporter)

Comment 14

3 years ago
Hi Paul,

I retested on Firefox 42 and on latest Firefox release, and also on latest FF Developer Edition. The issue is present. Tested in my working user account and from clean new. And again - no difference.
MacBook Pro retina 13" from early 2015 with i7-3.1, 16 Gb of RAM, Intel Iris 6100 and Mac OS X 10.11.3 Beta (15D13b)

Maybe issue appears because of 10.11.3 Beta, and I have an intention clean it and instal latest release of OS X, but not beta. Or maybe the problem in installation process, I upgraded Mac OS from 10.10 to 10.11, and the issue is here.

If you can't to reproduce, it's the good reason for me to go deeper, and figure out the reason. And maybe, issue not the Firefox.

Thanks, Paul.
Flags: needinfo?(ya.public0)
(Reporter)

Comment 15

3 years ago
Created attachment 8710075 [details]
YouTube - Firefox 43.0.4 - load fullscreen - 99C"
(Reporter)

Comment 16

3 years ago
Created attachment 8710078 [details]
Youtube - Safari - fullscreen - load - 68C"
(Reporter)

Updated

3 years ago
Attachment #8710078 - Attachment description: Safari - fullscreen - load.png → Youtube - Safari - fullscreen - load - 68C"
You welcome. And yes, this could be caused by the beta OS or some incompatibilities while upgrading OS from older version to newer one. 
If you do reinstall the OS, please retest this and report back the results. If this still reproduces, I will involve the development team to see their opinion.

Thanks,
Paul
Flags: needinfo?(ya.public0)
On your Mac, can you set media.ffmpeg.enabled to false (may be media.fragmented-mp4.enabled on older version)
And see if you still have the problem?

Thank you
(Reporter)

Comment 19

3 years ago
(In reply to Jean-Yves Avenard [:jya] from comment #18)
> On your Mac, can you set media.ffmpeg.enabled to false (may be
> media.fragmented-mp4.enabled on older version)
> And see if you still have the problem?
> 
> Thank you

Hi Jean, I tried with media.ffmpeg.enabled turned-off and turned-on, and nothing changed.

BUT, after I reinstall MacOS X El Capitan and problem disappeared.

Previous configuration was El Capitan 10.11.4 Beta for developers, that was installed above MacOS X 10.10

Now it is El Capitan 10.11.3 clear install.

The overheating issue solved:

- FF DE 46.0a2 (media.ffmpeg.enabled false by default) plays mentioned above video 1080p near 70C most of time. Temperature peaks to 80C.
- FF 44.0.1 plays video near 60-65C most of time. Temperature peaks to 75C.
- FF Nightly 47.0a1 plays video near 70C most of time.
- Safari 9.0.3 (11601.4.4) - plays video at 65C most of time.

Guys, I thank all of you for support.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(ya.public0)
Resolution: --- → INVALID
My MBP 13 was installed using the beta OS and I can't reproduce this issue. 

CPU does get up to 65C but being summer here we have an ambient temperature of 26 degrees in my house (it's 36 outside)

Would have been good to find out what the problem was. Very bizarre.
(Reporter)

Comment 21

2 years ago
(In reply to Jean-Yves Avenard [:jya] from comment #20)
> My MBP 13 was installed using the beta OS and I can't reproduce this issue. 
> 
> CPU does get up to 65C but being summer here we have an ambient temperature
> of 26 degrees in my house (it's 36 outside)
> 
> Would have been good to find out what the problem was. Very bizarre.

Hi Jean, one more thought about this problem I want to share. I always use resolution with more space, that looks like 1680 * 1050, and don't make a point about it, but maybe that's it?

In default display resolution, FF Nightly 47.0a1(2016-02-13) the temperature doesn't get up above 65C.
That's the resolution I use too.
You need to log in before you can comment on or make changes to this bug.