ReferenceError: AppConstants is not defined when trying to close the last conversation tab.

RESOLVED FIXED in Instantbird 45

Status

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: nhnt11, Assigned: aleth)

Tracking

({regression})

trunk
Instantbird 45

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Trying to close the tab using any of the following does nothing visible except causing the error below in the console: Cmd+W, Escape, middle clicking the tab, clicking the tab's x button, close/put on hold from the tab's context menu.

Timestamp: 12/7/15, 3:15:28 AM
Error: ReferenceError: AppConstants is not defined
Source File: chrome://global/content/globalOverlay.js
Line: 8

Clicking the window's x button successfully closes the tab with no errors in the console.

Closing the window causes conversations to be put in a weird state where it appears that Ib thinks that they are on hold, but they don't show up in the blist, and trying to join a channel that was closed results in it stuck in the "joining" state forever.
(Reporter)

Comment 1

3 years ago
> Closing the window causes conversations to be put in a weird state where it
> appears that Ib thinks that they are on hold, but they don't show up in the
> blist, and trying to join a channel that was closed results in it stuck in
> the "joining" state forever.

Scratch this part, turns out it was a result of me messing with an about:config flag and assuming that it was stuck at the "joining" state when really I just needed to wait another second.
(Assignee)

Comment 2

3 years ago
Attachment #8696701 - Flags: review?(nhnt11)
(Assignee)

Updated

3 years ago
Assignee: nobody → aleth
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Keywords: regression
(Assignee)

Updated

3 years ago
Attachment #8696701 - Flags: review?(clokep)
(Assignee)

Comment 3

3 years ago
Background: m-c is replacing some ifdefs with Appconstant.platform checks. See bug 1229519
Attachment #8696701 - Flags: review?(nhnt11)
Attachment #8696701 - Flags: review?(clokep)
Attachment #8696701 - Flags: review+
(Assignee)

Comment 4

3 years ago
https://hg.mozilla.org/comm-central/rev/982a9b6b77b2ce4907272ae4374a44e715650b8e
Bug 1230843 - Add AppConstants to instantbird.js. r=clokep
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Instantbird 45
You need to log in before you can comment on or make changes to this bug.