Animated favicon significantly reduces browser performance when displayed

RESOLVED DUPLICATE of bug 1210261

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1210261
2 years ago
2 years ago

People

(Reporter: Andrew Boyko, Unassigned)

Tracking

({perf, regression})

42 Branch
perf, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

1) Open http://vocaroo.com/ in a new tab
2) [optional] Add it to "Bookmarks Toolbar", either visible part or hidden under dropdown menu
3) Switch to other tabs and try to scroll (with smooth scrolling enabled in options, or use middle click scroll)


Actual results:

When this icon is displayed, page scrolling framerete decreases to 45fps (measured with eyes and layers.acceleration.draw-fps in about:config).
When you add this problematic favicon to the Bookmarks Toolbar, it loads after startap, so we get a persistent overall decrease in performance with non-obvious origin.


Expected results:

Resolve performance issue / [optional] Don't allow websites to have such bloated animated favicons (for reference, Google Chrome displays this favicon as a static image and there is no performance drop)
(Reporter)

Comment 1

2 years ago
My friend tested it on Firefox 40, and everything worked like a charm without any framedrops. Then I asked him to update to Firefox 42, and the issue revealed.
So, to summarize tested platforms:
Windows 10, Firefox 40 x86 - doesn't reproduce
Windows 10, Firefox 42 x86 - reproduces
Windows 10, Firefox 42 x86_64 - reproduces
Keywords: perf, regression, regressionwindow-wanted

Comment 2

2 years ago
I can reproduce on Aurora44.0a2, Beta43b9 and Firefox42.
Fortunately, This seems fixed on Nightly44.0a2 with/without e10s.

Fixed window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d60d5f8ffda4cb93b96c90fdd51ea4d3ce73a593&tochange=ac65a40dffcd91ebd3756fdc493e3c7f6c32d061

Fixed by: ac65a40dffcd	Mason Chang — Bug 1210261. Tick root refresh driver last. r=mattwoodrow
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Keywords: regressionwindow-wanted
Resolution: --- → DUPLICATE
Duplicate of bug: 1210261

Comment 3

2 years ago
typo
> Fortunately, This seems fixed on Nightly44.0a2 with/without e10s.
Fortunately, This seems fixed on Nightly45.0a1 with/without e10s.
You need to log in before you can comment on or make changes to this bug.