Last Comment Bug 123116 - mozilla crashed when I visit flash-enabled sites
: mozilla crashed when I visit flash-enabled sites
Status: RESOLVED DUPLICATE of bug 58339
:
Product: SeaMonkey
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 Linux
: -- critical (vote)
: ---
Assigned To: Asa Dotzler [:asa]
: Doron Rosenberg (IBM)
:
Mentors:
http://www.daum.net
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-01 22:30 PST by debfolder
Modified: 2005-11-22 15:25 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description debfolder 2002-02-01 22:30:49 PST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20020121
BuildID:    Mozilla 0.9.7 - 20020121

no matter which version I have, every mozilla under linux crash when people
visit flash-enabled sites with using sound-players.
(ie. timidity - midi player, xmms, realplayer -- such as resource-eating too
much-apps. mostly using OSS modules.)

Reproducible: Always
Steps to Reproduce:
1.Excute xmms using OSS module(or timidity) and play musics.
2.Invoke your mozilla and surf the web.
3.when you visit flash-enabled(, which has shockwave or flash applets) sites,
mozilla will stop. To solve this problem, you must kill or close the
sound-playing applications(explained in Description). 

Actual Results:  stops and sleeps until finishing the sound-apps.
nothing works. I can't click the toolbars and menus.
mouse pointer is not turned into finger-form.
To make the sounds going on-, should kill mozilla with window-manager's   kill
option. After that, if visit into the same page, mozilla vanishs from my root
window(he dies).

Expected Results:  I wish the mozilla can surf flash-enabled site without
intervening sound-apps.
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2002-02-01 23:11:29 PST
Everybody wishes that.  :)  Too bad the flash _plugin_ is where the bug is. 
Netscape 4 experiences the same exact problems.  Downgrading to Flash 4 fixes
the problems in both Netscape and Mozilla.  Running mozilla through esd or
equivalent fixes the problems too.

Duplicate of "Flash plugin (presumably 5.0 r47 only) hangs mozilla, when it's
trying to play audio, while audio device is active. (Reproducible with some
[e.g. es1371] sound driver)".  That has some details of how to run mozilla to
avoid this problem.

*** This bug has been marked as a duplicate of 58339 ***

Note You need to log in before you can comment on or make changes to this bug.