Closed Bug 1231162 Opened 6 years ago Closed 6 years ago

cursor is "jumping around" when typing into Facebook status update and comment fields

Categories

(Firefox for Android Graveyard :: Keyboards and IME, defect)

Unspecified
Android
defect
Not set
normal

Tracking

(fennec+)

RESOLVED DUPLICATE of bug 1235632
Tracking Status
fennec + ---

People

(Reporter: hsteen, Assigned: jchen)

References

()

Details

Attachments

(1 file)

Attached file Test case / demo
When you type into status updates and/or comment fields on Facebook using Nightly on Android, the cursor behaves erratically in some situations. If you try to go back and correct an earlier error, the cursor doesn't always stay where you placed it once you start typing. Even more infuriating: if you've typed something elsewhere and move cursor back to the end of the text, then start typing, sometimes the cursor will jump back to where you previously were and it's apparently impossible to get it to stay at the end.

This is probably a follow-up to the fix we did for bug 549674

Fun fact: if there is a Japanese character *somewhere* in the input, it stops misbehaving :)
Which keyboard are you using, and on which device, hallvors?
tracking-fennec: --- → ?
Flags: needinfo?(hsteen)
OS: Unspecified → Android
I'm seeing this on a Moto X phone, using the normal built-in on-screen keyboards for Norwegian and English and Google Japanese Input for Japanese.
Flags: needinfo?(hsteen)
Ioana would your team check if this a regression?
Flags: needinfo?(ioana.chiorean)
Using a Nexus 6 (Android 6.0) using English (US) - Google Keyboard, I can reproduce the issue:
on all branches. Note that "Show correction suggestions" is enabled in Settings.

-Place cursor before the word "World" 
=>the cursor jumps to the end
-Touch after the word "World" to attempt to make sure the cursor will stay there and type a backspace
=>cursor jumps back to before "World" and the space is deleted


I cannot reproduce the issue with "Show correction suggestions" disabled.
Flags: needinfo?(ioana.chiorean)
Assignee: nobody → nchen
tracking-fennec: ? → +
I think this is the same as the "touch caret being wonky under APZ" bug
Flags: needinfo?(markcapella)
(bug 1235632) ... does sound like a dup ... for ex there, see: [0]

[0] https://www.dropbox.com/s/oib80kcgmi9g5fc/bug_1235632_cursorJump.mp4?dl=0
Flags: needinfo?(markcapella)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1235632
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.