Crashes when typing into a form also updated by JS (java.lang.IllegalArgumentException: newEnd does not match text at org.mozilla.gecko.GeckoEditable.onTextChange(GeckoEditable.java))

RESOLVED DUPLICATE of bug 1051556

Status

()

Firefox for Android
Keyboards and IME
RESOLVED DUPLICATE of bug 1051556
2 years ago
2 years ago

People

(Reporter: hallvors, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8696719 [details]
wc1170d.htm

Typing a few letters into the textarea in the attached page reliably crashes nightly on Android for me. Seems it's not only me hitting this..:

https://crash-stats.mozilla.com/search/?signature=~newEnd&_facets=signature&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#facet-signature
(Reporter)

Comment 1

2 years ago
Masayuki, are you familiar with this code?
Flags: needinfo?(masayuki)
Hmm, recent regression? If so, I must be guilty.
Flags: needinfo?(masayuki)
I think it's the same as bug 1051556, which has some patches.
(Reporter)

Comment 4

2 years ago
I have no idea if it's recent or not, sorry. We can leave this till we can test a build with those bug 1051556 patches.
Bug 1051556 landed – can you still repro?
Flags: needinfo?(hsteen)
(Reporter)

Comment 6

2 years ago
No \o/
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(hsteen)
Resolution: --- → DUPLICATE
Duplicate of bug: 1051556
You need to log in before you can comment on or make changes to this bug.