Closed Bug 123121 Opened 18 years ago Closed 13 years ago

LABELING after WATCHING message removes WATCH?

Categories

(SeaMonkey :: MailNews: Message Display, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: patrick.hendriks+bugzilla, Unassigned)

References

(Blocks 1 open bug, )

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.8+)
Gecko/20020131
BuildID:    2002013103

When setting a LABEL for a message in a newsgroup, after it has been marked
WATCHED removes the watching eye icon from the message.

One needs to press W twice to bring the eye back

Reproducible: Always
Steps to Reproduce:
1. mark thread watched
2. apply label to first message of thread
3. watch the eye icon

Actual Results:  eye disappears

Expected Results:  label and watch would work together
QA Contact: esther → laurel
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
The watched icon reappears once you exit the group and return without reapplying
the watch command and the thread is indeed in watched state.

We have a couple other instances where the watch/ignore icons aren't behaving
correctly and change display state after exit.
Might want to consider fixing this now that we have news filtering and multiple
actions, it may become more apparent, more annoying.
Keywords: nsbeta1
*** Bug 180887 has been marked as a duplicate of this bug. ***
Mail triage team: nsbeta1-
Keywords: nsbeta1-
Keywords: nsbeta1
Blocks: 214286
Product: Browser → Seamonkey
Assignee: sspitzer → mail
WFM - not seen on SM trunk 
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060625 SeaMonkey/1.5a
bug 227287 was possibly a dup of this
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.