debugger statement in DevTools Console does not activate debugger

RESOLVED DUPLICATE of bug 1132501

Status

RESOLVED DUPLICATE of bug 1132501
3 years ago
4 months ago

People

(Reporter: sime.vidas, Unassigned)

Tracking

42 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8696868 [details]
CVeGT1oUEAAxMQz.mp4

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

In Chrome and Edge’s DevTools, it is possible to type `debugger; fn()` in the Console to activate the debugger and step into the `fn()` function call. Please see the short videos in this Twitter thread: https://twitter.com/kentcdodds/status/673154350076719104, or see the attached video.


Actual results:

Currently, Firefox’s console just ignores the `debugger` statement.



Expected results:

Firefox DevTools should implement this functionality.
Hi Šime,

This may be considered as an enhancement for the developer tools component. I'll assign a component to it to see what is the developers opinion on this.


Thanks,
Paul.
Component: Untriaged → Developer Tools: Console

Comment 2

3 years ago
The debugger statement works if debugger has been opened in DevTools.
Status: UNCONFIRMED → NEW
Depends on: 1132501
Ever confirmed: true
This is going to be fixed very soon in bug 1132501.
This should be fixed by bug .
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1132501
Oops, well you get the point :)

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.