Closed Bug 1231635 Opened 4 years ago Closed 4 years ago

[Static Analysis][Uninitialized scalar field] Function nsSHEntry from nsSHEntry.cpp.cpp

Categories

(Core :: DOM: Navigation, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla45
Tracking Status
firefox45 --- fixed

People

(Reporter: andi, Assigned: andi)

References

(Blocks 1 open bug)

Details

(Keywords: coverity, Whiteboard: CID 1325962)

Attachments

(1 file)

The Static Analysis tool Coverity added that variable member mLoadReplace is not attributed a value in the constructor: nsSHEntry::nsSHEntry()
Most likely this is not a bug looking through code but i think we should still give it an ivitial value (false), as the rest of the scalar have.
Attached patch Bug 1231635.diffSplinter Review
Attachment #8697235 - Flags: review?(bzbarsky)
Comment on attachment 8697235 [details] [diff] [review]
Bug 1231635.diff

r=me
Attachment #8697235 - Flags: review?(bzbarsky) → review+
Assignee: nobody → bogdan.postelnicu
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/f9e48a6a905a
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
You need to log in before you can comment on or make changes to this bug.