Apps icon transparent when going home from apps

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Homescreen
RESOLVED WONTFIX
3 years ago
11 months ago

People

(Reporter: VladimirBelonenko, Assigned: cwiiis)

Tracking

({polish, regression})

unspecified
ARM
Gonk (Firefox OS)
polish, regression

Firefox Tracking Flags

(b2g-v2.5 unaffected, b2g-master affected)

Details

(Whiteboard: [2.6-Daily-Testing][Spark][systemsfe], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8697711 [details]
logcat_20151211_1459.txt

Description:
When user opens an app and selects home button, the app diminishes slowly.

Repro Steps:
1) Update a Aries to 20151211114049
2) Open Web Browser
3) Select Home Button
4) Observe that app icon transparent slowly disappears .

Actual:
App slowly closes slowly after pressing home button icon. 

Expected:
When User selects home button the app should diminish quickly without any 
effects.

Notes: This issue occurs on any apps especially with red icons.

Environmental Variables:
Device: Aries Master 2.6 kk full flash
Build ID: 20151211114049
Gaia: d886e152b42e557db612470d3417fe2947cbdeee
Gecko: 754b4805a65cab4f3aca99899227acc44ba4fb20
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 45.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 3/3
See attached: video clip and logcat
(Reporter)

Comment 1

3 years ago
This issue still occurs on Flame 2.6 
Result: App slowly closes slowly after pressing home button and Icon flickers.

Environmental Variables:
Device: Flame 2.6 kk full flash
Build ID: 20151211030233
Gaia: d886e152b42e557db612470d3417fe2947cbdeee
Gecko: 754b4805a65cab4f3aca99899227acc44ba4fb20
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

This issue does not occurs on Flame 2.5 
Result: When User selects home button the app should diminish quickly without any 
effects.

Environmental Variables:
Device: Flame 2.5 kk full flash
Build ID: 20151211164817
Gaia: 062e0fa48c1b5d5156f6911a5a4519128fac3231
Gecko: ded0306e0d78528cdcb237c8b05543390f10ec96
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage+]
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(jmercado)
Keywords: regression
Minor issue, not nominating to block.  Let's get a window here though.
status-b2g-v2.5: affected → unaffected
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted

Updated

3 years ago
QA Contact: jthomas
(Assignee)

Comment 3

3 years ago
We can work around this - the issue here is that the CSS transition isn't applying until we go back to the application. Interesting that this is a regression, we should still find the window because whatever caused it may cause other unexpected issues, but I expect that this is valid behaviour and we'll need to work around it.
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
Keywords: polish
(Assignee)

Updated

3 years ago
Whiteboard: [2.6-Daily-Testing][Spark] → [2.6-Daily-Testing][Spark][systemsfe]

Comment 4

3 years ago
Caused by changes made in Bug 1214388

B2g Inbound Regression Window

Last Working
Environmental Variables:
Device: Flame 2.6
BuildID: 20151113023230
Gaia: 3fb68dc7084a1339eb18a87a1a593a51448e56a8
Gecko: fa99f07ef603692363a70eebee9b198144bbd62a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

First Broken
Environmental Variables:
Device: Flame 2.6
BuildID: 20151113030235
Gaia: 0f90702660d20024603350024b693e3585332eea
Gecko: 1f534cb44c4b60deb86ed2edce1bb254f48c49ca
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Last Working gaia / First Broken gecko - Not affected
Gaia: 3fb68dc7084a1339eb18a87a1a593a51448e56a8
Gecko: 1f534cb44c4b60deb86ed2edce1bb254f48c49ca

Last Working gecko / First Broken gaia - Affected
Gecko: fa99f07ef603692363a70eebee9b198144bbd62a
Gaia: 0f90702660d20024603350024b693e3585332eea

Gaia Pushlog:
https://github.com/mozilla-b2g/gaia/compare/3fb68dc7084a1339eb18a87a1a593a51448e56a8...0f90702660d20024603350024b693e3585332eea
Blocks: 1214388
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Etienne the changes for bug 1214388 seem to have caused this issue.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(etienne)
(In reply to Jayme Mercado [:JMercado] from comment #5)
> Etienne the changes for bug 1214388 seem to have caused this issue.  Can you
> please take a look?

I think bug 1214388 was probably hiding the issue by forcing an expensive reflow (and repaint).
Looks like the transition from [1] is playing when coming back...

Maybe we shouldn't transition when going back to full opacity by removing the |.launching| class.


[1] https://github.com/mozilla-b2g/gaia/blob/ee43a95f2bbe39c5ac8c9fcdec76749a56c02f2e/apps/homescreen/style/apps-panel.css#L48-L50
Flags: needinfo?(etienne)
(Assignee)

Updated

11 months ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.