“Permission denied to access property 'print' ” in Firefox 43.0 when printing PDF. Changing 'pdfjs.disabled' not helped

RESOLVED DUPLICATE of bug 911444

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 911444
2 years ago
2 years ago

People

(Reporter: Sanal, Unassigned)

Tracking

43 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151208100201

Steps to reproduce:

I am using Dynamic Report in Servlet to generate a PDF and out put it to jsp page using the code

    report.toPdf(response.getOutputStream());

In Jquery I am loading the pdf in a new window as a popup

    var newWindow = window.open(url, 'name', 'height=800,width=1000');
            if (window.focus) {
                newWindow.focus();
                setTimeout(function() {
                    newWindow.print();
                }, 2000);
            }


Actual results:

But this returns an error

Error: Permission denied to access property "print"
Firefox version is 43.0 . I tried changing 'pdfjs.disabled' to 'true' in about:config, but that's not helping: when that's set and tried to print, the window closes automatically right-away and the pdf gets auto-saved and console shows the error:

"NS_ERROR_NOT_AVAILABLE:"

On removing the: 

 setTimeout(function() {
                    newWindow.print();
                }, 2000);

and writting: 

 newWindow.print(); 

prints a blank page.


Expected results:

Want to print the pdf file directly, no need for any preview. No proper solution was found for this problem anywhere.
No help from here
https://bugzilla.mozilla.org/show_bug.cgi?id=911444
and
https://bugzilla.mozilla.org/show_bug.cgi?id=792816
(Reporter)

Updated

2 years ago
Severity: normal → critical
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64

Updated

2 years ago
Severity: critical → normal

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 911444
(Reporter)

Comment 2

2 years ago
(In reply to Loic from comment #1)
> 
> *** This bug has been marked as a duplicate of bug 911444 ***

That solutions given in that post doesn't Resolve my problem.

Comment 3

2 years ago
No need to create a duplicate, just follow the revious bug report.
(Reporter)

Comment 4

2 years ago
OK...
You need to log in before you can comment on or make changes to this bug.