Closed Bug 1232177 Opened 4 years ago Closed 4 years ago

[tracking] Support Greasemonkey and Scriptish as a web extension

Categories

(WebExtensions :: Untriaged, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: erikvvold, Unassigned)

References

Details

I am quoting Kev Needham from https://blog.mozilla.org/addons/2015/08/21/the-future-of-developing-firefox-add-ons/:

"We want to reiterate our commitment to our add-on development community, and will work with you in porting extensions, designing new APIs, and creating innovative new add-ons that make Firefox great."

If this is true then Mozilla will need to develop many apis in order to support Greasemoney and Scriptish..  if it is not true then it will be impossible to port these extensions which I want to see done and would have been possible with the sdk.
Please inform me as to how porting these extensions will be possible, because afaict it is not possible with current plans.
Flags: needinfo?(kev)
Native.js looks like a bad approach as I describe in bug 1199718, but I am making this bug depend on a resolution of bug 1199718 because other bugs like this one are doing the same.
Depends on: 1199718
Flags: needinfo?(kev)
Is there something that I am missing? There are add-ons like Tampermonkey which almost works in Firefox which do a Greasemonkey or Scriptish content script per page. The only thing that is obvious to me is the configuration of the add-on in about:addons, that's something we've discussed and is not currently a priority. There are multiple other ways to do the preference management.

https://chrome.google.com/webstore/detail/tampermonkey/dhdgffkkebhmkfjojejmpbldmpobfkfo

If there's something specific I'm missing here, please let me know.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 1334174
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.