Closed Bug 1232184 Opened 5 years ago Closed 5 years ago

[e10s+APZ] Flash plugin windows flicker on and off when I turn the mouse wheel even though the page is not actually scroll

Categories

(Core :: Layout, defect)

45 Branch
Unspecified
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1193055
Tracking Status
e10s m8+ ---
firefox45 --- unaffected
firefox46 --- fixed

People

(Reporter: alice0775, Assigned: jimm)

References

(Blocks 1 open bug, )

Details

(Keywords: regression)

Attachments

(2 files)

127.61 KB, application/x-shockwave-flash
Details
53.09 KB, application/x-shockwave-flash
Details
Attached file choudanse7.swf
After landing Bug 1137944, a bad effect appears.
it is worse than before landing it.

Steps to reproduce:
1. Open url or attachment
2 [review]. Turn mouse wheel

Actual Results:
Flash plugin windows flicker on and off

Actual Results:
Should not flicker,

Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2a51d8766dfbfd272518ab3a47d2ca5f452dc971&tochange=e1e281f04f27

Regressed by Bug 1137944
Summary: [e10s] Flash plugin windows flicker on and off when I turn the mouse wheel despite the page is not scrolling even though the page is not actually scroll → [e10s] Flash plugin windows flicker on and off when I turn the mouse wheel even though the page is not actually scroll
another testcase:
STR
1. Open WheelTest.swf (notwork on local file system)
2. Turn mouse wheel 

Actual Results:
Mouse wheel event does not count while the flash object is hidden

Expected Results:
Mouse wheel event should count continuously .
I don't see any flickering in WheelTest.swf. The flash applet does appear to have an issue with picking up mouse wheel events though. Potentially a bug in nsGfxScrollFrame which hides plugin windows as a result of scroll events.
Disappears WheelTest.swf while rotating the wheel.
And event count is increased only one instead number of wheel tick.
Flags: needinfo?
Flags: needinfo?(jmathies)
Flags: needinfo?
This is currently apz specific, which is interesting. DOM scroll doesn't trigger it.
I think the fix for bug 1193055 will address this assuming apz knows if a content page is scrollable.
Depends on: 1193055
No longer depends on: 1212813, 1232181
Flags: needinfo?(jmathies)
Summary: [e10s] Flash plugin windows flicker on and off when I turn the mouse wheel even though the page is not actually scroll → [e10s+APZ] Flash plugin windows flicker on and off when I turn the mouse wheel even though the page is not actually scroll
Version: Trunk → 45 Branch
fixed by bug 1193055
Assignee: nobody → jmathies
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1193055
See Also: → 1240359
You need to log in before you can comment on or make changes to this bug.