Closed Bug 1232254 Opened 6 years ago Closed 5 years ago

Ugly active hello icon when placed in additional tools and features

Categories

(Hello (Loop) :: Client, defect, P3)

defect

Tracking

(firefox45- wontfix, firefox46- wontfix, firefox47 wontfix, firefox48 wontfix, firefox49 affected)

RESOLVED WONTFIX
Tracking Status
firefox45 - wontfix
firefox46 - wontfix
firefox47 --- wontfix
firefox48 --- wontfix
firefox49 --- affected

People

(Reporter: bogdan_maris, Unassigned)

References

Details

(Keywords: polish, regression)

Attachments

(1 file)

Affected builds:
- latest Nighty 45.0a1

Affected OS`s:
- Windows 7 64-bit
- Ubuntu 14.04 32-bit
- Mac OS X 10.11.1

STR:
1. Start Firefox
2. Start a conversation
3. Enter Customize
4. Move Hello icon to Additional Tools and Features

Expected results: Hello icon is displayed properly.

Actual results: Hello icon is broken when active and placed to Additional Tools.

Notes:
- Screenshot attached showing the issue.
- This is a recent regression 

First good: 2015-12-03
First bad: 2015-12-04

M-C:

Last good revision: 9d8af47837101c8f4ce67930e5094a59ed9942a6
First bad revision: 528fc18a86d3f6e6bec37190522a46853a846665
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9d8af47837101c8f4ce67930e5094a59ed9942a6&tochange=528fc18a86d3f6e6bec37190522a46853a846665

M-I:

Last good revision: cd2a99c12ed311a71bfb6b444acd69379036a8e2
First bad revision: 92499b34eeffbfdaf5df19f63c464988435356db
Pushlog:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=cd2a99c12ed311a71bfb6b444acd69379036a8e2&tochange=92499b34eeffbfdaf5df19f63c464988435356db

I don't think that M-I range is accurate since it points to Bug 1225514.
Rank: 39
Priority: -- → P3
[Tracking Requested - why for this release]:
obvious visual regression
Note: This only occurs whilst you're in a conversation. It doesn't happen with the default icon state.

So to see this you have to either: 

- move the Hello button into "Additional Tools & Features" (where you then can't access it) whilst you're in a conversation

or

- you've previously sent someone a link, then you put the button into the "Additional Tools & Features" and then sometime later you get a notification and then visit the customize option again.

Its not good, but given the more difficult ways to reproduce it, I don't think it warrants priority - I think we should get bug 1233701 fixed first, and then re-check this after that one.
Depends on: 1233701
Just like Mark said at the end of comment #2. Not tracking. However, happy to take a safe uplift to fix it.
Flags: needinfo?(standard8)
Keywords: polish
Jim, sorry I've no idea why you've needinfoed me on this when we've already prioritised it.
Flags: needinfo?(standard8) → needinfo?(jmathies)
Sorry didn't realize the P3 was from your team.
Flags: needinfo?(jmathies)
Can you still reproduce this?
Flags: needinfo?(bogdan.maris)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
Flags: needinfo?(bogdan.maris)
FWIW, this sure looks like a hidpi -moz-image-region bug?
You need to log in before you can comment on or make changes to this bug.