Closed Bug 1232594 Opened 6 years ago Closed 6 years ago

[Dialer]"Close" button shows as a rectangular button on multiple calls.

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.6+, b2g-v2.5 affected, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.6+
Tracking Status
b2g-v2.5 --- affected
b2g-master --- verified

People

(Reporter: lixia, Assigned: gsvelto)

References

Details

Attachments

(4 files)

[1.Description]:
[Aries KK v2.5&master][Flame v2.5&master][Dialer]When making a multiple call, the "Close" button is shown as a rectangular button on conference call number list page.

Found at: 14:28
Attach: logcat_1428.txt and Flame_master.png

[2.Testing Steps]: 
1. Make a multi-party call.
2. Tap the ">" icon to try to view the phone number list of the multi-party call.

[3.Expected Result]: 
2. The "Close" button should appear as an oval button.

[4.Actual Result]: 
2. The "Close" button is shown as a rectangular button similar to other options in the menu.

[5.Reproduction build]: 
Device: Flame master_512mb (affected)
Build ID               20151214150211
Gaia Revision          ad15b4f1f50f4e28170a069f049e5bdeec8d15cc
Gaia Date              2015-12-13 23:23:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/06ab805e14b5e6d8a8a99c7846c8fde163a9e5d7
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151214.184408
Firmware Date          Mon Dec 14 18:44:23 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK master (affected)
Build ID               20151215010221
Gaia Revision          ad15b4f1f50f4e28170a069f049e5bdeec8d15cc
Gaia Date              2015-12-13 23:23:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ae37fdb042c07c0cb9d0afcd41372a96454f4f4f
Gecko Version          46.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151215.002304
Firmware Date          Tue Dec 15 00:23:12 UTC 2015
Bootloader             s1

Device: Flame 2.5_512mb (affected)
Build ID               20151214083757
Gaia Revision          062e0fa48c1b5d5156f6911a5a4519128fac3231
Gaia Date              2015-12-11 15:06:09
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/d76a9f65b6ba2ab587d3a0fb5119773ba68720a0
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151214.074606
Firmware Date          Mon Dec 14 07:46:17 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (affected)
Build ID               20151214084334
Gaia Revision          062e0fa48c1b5d5156f6911a5a4519128fac3231
Gaia Date              2015-12-11 15:06:09
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/d76a9f65b6ba2ab587d3a0fb5119773ba68720a0
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151214.074854
Firmware Date          Mon Dec 14 07:49:02 UTC 2015
Bootloader             s1


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Attached image Flame_master.png
Attached file logcat_1428.txt
See Also: → 1196268
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
Since the functionality is not broken, lets not block on it for 2.5 but will be fixed for 2.6
blocking-b2g: 2.5? → 2.6+
Taking, this is an easy fix.
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Comment on attachment 8698423 [details] [review]
[gaia] gabrielesvelto:bug-1232594-close-button-conference-group-info-fix > mozilla-b2g:master

This is a really simple fix. Shared action menus need to have the last element wrapped into a span with the last-button-container CSS class set to have a look that's consistent with the rest of the system. I added such an element to the HTML code, no JS/CSS changes were needed.
Attachment #8698423 - Flags: review?(thills)
Comment on attachment 8698423 [details] [review]
[gaia] gabrielesvelto:bug-1232594-close-button-conference-group-info-fix > mozilla-b2g:master

Hi Gabriele,

Looks good.  I did test out as well.

Thanks,

-tamara
Attachment #8698423 - Flags: review?(thills) → review+
Thanks Tamara, merged in gaia/master

https://github.com/mozilla-b2g/gaia/commit/fb53b632e1d5d481775d41a47578b45aa28548e1
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Gabriele, maybe you can ask for approval for 2.5 ?
Flags: needinfo?(gsvelto)
No Repro per this build: 

RESULT when combine 2 calls to form a conference call the CLOSE button underneath is an Oval shape as expected. 

Environmental Variables:
Device: Aries 2.6
BuildID: 20151217122751
Gaia: 140f6ee998b07b354d1841fed902056179c90100
Gecko: 0711218a018d912036f7d3be2ae2649e213cfb85
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 46.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

REPRO per builds: 

Environmental Variables:
Device: Aries 2.5
BuildID: 20151217165758
Gaia: eeed1451e0e48b63abe3199e4d6906adc2a762d2
Gecko: 94905dc59d7286b7fe627afbcddafc495894f08d
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 44.0 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Environmental Variables:
Device: Flame 2.5
BuildID: 20151216102959
Gaia: 062e0fa48c1b5d5156f6911a5a4519128fac3231
Gecko: ff08f85000b57964f04d4421c01784d22e0f6316
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Flame 2.5 and Aries 2.5 not fixed.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: verifyme
If this gets approved for uplift to 2.5 please add the verifyme tag again.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Comment on attachment 8698423 [details] [review]
[gaia] gabrielesvelto:bug-1232594-close-button-conference-group-info-fix > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): -
[User impact] if declined: The cancel button isn't shown in a way consistent with other menus
[Testing completed]: Tested on a device and in the emulator
[Risk to taking this patch] (and alternatives if risky): None, this is just a markup change
[String changes made]: None
Flags: needinfo?(gsvelto)
Attachment #8698423 - Flags: approval-gaia-v2.5?
Comment on attachment 8698423 [details] [review]
[gaia] gabrielesvelto:bug-1232594-close-button-conference-group-info-fix > mozilla-b2g:master

Limiting 2.5 only to TV patches. Foxfooders getting updates from master/b2g-ota branch. Removing the uplift nomination.

Thank you
Attachment #8698423 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5-
You need to log in before you can comment on or make changes to this bug.