Closed Bug 1232795 Opened 7 years ago Closed 7 years ago

[EME] Remove VIDEO_EME_DISABLED telemetry probe

Categories

(Core :: Audio/Video: Playback, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla46
Tracking Status
firefox46 --- fixed

People

(Reporter: cpearce, Assigned: cpearce)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

The VIDEO_EME_DISABLED probe has expired. It reports only when Adobe's EME GMP is enabled, and reports whether EME is enabled. However it relies on manually checking the "media.gmp-adobe-eme.enabled" pref which isn't set by default, it's a hidden pref which is assumed to be true by the GMPPref Util, but not by the path we were accessing. So we actually aren't likely to collect any data via this probe, and indeed we don't have any results returned AFAICT.
Attachment #8698625 - Flags: review?(spohl.mozilla.bugs) → review+
Comment on attachment 8698625 [details]
MozReview Request: Bug 1232795 - Remove VIDEO_EME_DISABLED telemetry probe. r?spohl

https://reviewboard.mozilla.org/r/28049/#review25125
Comment on attachment 8698626 [details]
MozReview Request: Bug 1232799 - Remove KEY_PLUGIN_TRIAL_CREATE pref from GMPProvider and friends. r?spohl

https://reviewboard.mozilla.org/r/28051/#review25123
Attachment #8698626 - Flags: review?(spohl.mozilla.bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/d5d601cc0beb
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
You need to log in before you can comment on or make changes to this bug.