Closed Bug 1232874 Opened 5 years ago Closed 3 years ago

[B2G] Option to change server

Categories

(Testing :: mozregression, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: nhirata, Assigned: parkouss)

References

Details

Attachments

(1 file)

Contractors have their own build server which they mirrored PVT build server.

It would be nice to be able to switch from pvtbuild or taskcluster or a different repo server in terms of build selection.

Further discussion will probably be needed in terms of searching for the appropriate build corresponding to the hg rev.
See Also: → 1241919
So I assume we want to override NIGHTLY_BASE_URL in there:

https://github.com/mozilla/mozregression/blob/647a8d4b230b97f146f081df72693ae22c582f05/mozregression/fetch_configs.py#L30

Currently mozregression automatically determine to use PVT build server (e.g., archive.mozilla.org) and taskcluster. It does so with a couple of rules, the first one being if we have a hg rev as good or bad parameter, we use taskcluster (it would be a pain - and slow - to get pvt builds based on the hg changeset, due to the folders structure).

Changing the base url for PVT builds is easy, I'll work on it. Do we need something more here ?
Flags: needinfo?(nhirata.bugzilla)
(In reply to Julien Pagès (:parkouss) from comment #1)
> So I assume we want to override NIGHTLY_BASE_URL in there:
> 
> https://github.com/mozilla/mozregression/blob/
> 647a8d4b230b97f146f081df72693ae22c582f05/mozregression/fetch_configs.py#L30
> 
> Currently mozregression automatically determine to use PVT build server
> (e.g., archive.mozilla.org) and taskcluster. It does so with a couple of
> rules, the first one being if we have a hg rev as good or bad parameter, we
> use taskcluster (it would be a pain - and slow - to get pvt builds based on
> the hg changeset, due to the folders structure).
> 
> Changing the base url for PVT builds is easy, I'll work on it. Do we need
> something more here ?

I'm not sure how ktucker and company are storing the data.  I believe they are storing it in a similar fashion to pvtbuild server ( as it makes sense to us in this fashion for regression window hunting ).

Kevin or Jayme, can you comment please?
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(ktucker)
Flags: needinfo?(jmercado)
Our Flame directories are just clones of the directories from the PVT server that we keep as long as possible (Right now we have builds back to September of 2014).  We have emulated the with Aries as much as possible while still working within the means of task cluster.
Flags: needinfo?(jmercado)
This patches add an option "archive-base-url" accessible from the command line, the config file and the GUI interface.

I don't think it solves everything here, because we want to download b2g devices (aries, flames) builds from the server - and currently mozregression only uses taskcluster for those builds.

Though this is a start, and it was asked in bug 1241919 anyway.
Assignee: nobody → j.parkouss
Status: NEW → ASSIGNED
Attachment #8712271 - Flags: review?(wlachance)
(In reply to Jayme Mercado [:JMercado] from comment #3)
> Our Flame directories are just clones of the directories from the PVT server
> that we keep as long as possible (Right now we have builds back to September
> of 2014).  We have emulated the with Aries as much as possible while still
> working within the means of task cluster.

Oh, can you point me to the url of your clone server, or to the original one ? I know a bit the structure of the server but mainly for firefox/thunderbird/fennec builds.
Flags: needinfo?(jmercado)
Our clone isn't accessible from the outside, but the link to the pvt tinderbox builds is https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/tinderbox-builds/

We take Flame-KK-eng builds for b2g-inbound, mozilla-inbound, and mozilla-central.
Flags: needinfo?(jmercado)
Flags: needinfo?(ktucker)
Attachment #8712271 - Flags: review?(wlachance) → review+
Ok, so the landed patches do not fix the issue, because we don't crawl the server for b2g builds (we only look in taskcluster currently).

Anyway it was requested per bug 1241919.

https://github.com/mozilla/mozregression/commit/6d7d4863be0e102b60c519407f3aee9fba20a77c
https://github.com/mozilla/mozregression/commit/854c4a640bdfc9130b046c18c8896228518813a5
B2G is gone.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.