Closed Bug 1233035 Opened 4 years ago Closed 4 years ago

Firefox profile got corrupted: Firefox can't start anymore with this profile

Categories

(Firefox OS Graveyard :: B2gInstaller, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jlorenzo, Unassigned)

References

Details

Attachments

(1 file)

Attached file Firefox process logs
Pre-requisite
Have another instance of Firefox running

STR
1. Start another instance of Firefox (--no-remote -P)
2. Create a new profile of Firefox. Install b2g-installer and the addon
3. (Not sure of this step) Update Nightly from the 1st instance running
4. (Not sure of this step) Leave the newly created instance open while the other restart
5. Close the newly created unstance and reopen it

Results
Firefox can't start up with the new profile, but has no trouble loading the old one (even if you restart it). See attached logs for details.
This bug is not related to the addon. I created a fresh profile and that new one doesn't boot up too. I'll find what's the correct component.
It doesn't seem related to the profile after all. I rebooted my computer and was able to have 2 instances open. When I opened back my b2g-installer session, I was asked to restore my tabs. I guess a crashed occurred in the middle. 

A new nightly update shown up and I retried the STRs in comment 0, I couldn't reproduce. Hence I'm not exactly sure on how to reproduce the shut down crash. I looked up in bugzilla to see if there was something similar, that could help me to diagnose the problem. I couldn't find anything.

Hence, I'm closing this bug, I'll reopen it if I get more information.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.