FF43 does not play VP9 video from Youtube

RESOLVED DUPLICATE of bug 1233970

Status

()

RESOLVED DUPLICATE of bug 1233970
3 years ago
2 years ago

People

(Reporter: wip.the.gruik, Unassigned)

Tracking

43 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Mozilla/5.0 (Windows NT 5.1; rv:43.0) Gecko/20100101 Firefox/43.0

Reproducible with Firefox 43.0 on Windows XP.
Verified with a fresh install, new profile, no add-on installed.

Steps to reproduce:
 - ensure that Flash plugin is either not installed or disabled
 - in about:config, set the property "media.mediasource.webm.enabled" to "true" 
 - go to youtube.com to watch any recent video (that's to say having HTML5 support)

Actual results:
 video are streamed using VP8 codec, restricting display to the 360p resolution only

Expected results:
 video should be streamed using VP9 codec, allowing higher - and usable - resolutions

Although not officially enabled, WEBM/VP9 used to work flawlessly since Firefox 41.
It still works fine with Dev Edition (44.0a2|20151214004008) and the latest nightly (46.0a1|20151216030229).

The site html5test.com tells that "WebM with VP9 support" is available.
Spoofing the user-agent back to Firefox 42 does not change anything, in case of Youtube sniffing.
I cannot see any error either in the console nor the browser console.

Updated

3 years ago
Component: General → Audio/Video: Playback
Product: Firefox → Core

Comment 1

3 years ago
Could you test with a clean profile with FF43, please.
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

I tested with FF43 on Win 7, it works with this video https://www.youtube.com/watch?v=Ex8kDMKnLaE
Flags: needinfo?(wip.the.gruik)
Please try with a clean profile, or start in safe mode.

For your information, you do not need to enable media.mediasource.webm.enabled to true. WebM mediasource will automatically be enabled on Windows XP (it's automatically enabled on all machines not supporting h264)
Also, please go to this page http://w3c-test.org/media-source/mediasource-is-type-supported.html
and save the output here.

What does youtube.com/html5 reports?

Thank you in advance for your help. MSE on Windows XP is now enabled by default in 43 and you should be able to get high quality video without flash even on Windows XP

Comment 4

3 years ago
I can confirm this on my XP box also (XPProSP3, FF43.0.1)

In fact first noticed on FF42 out of the blue, even on videos
already watched under VP9 480p/720p were suddenly VP8 360p
only with a new "missing options?" entry under the settings icon
in the html5 player, which takes you to a page which unceremoniously
tells you to use Chrome or a newer OS.

May be something Youtube has done to intentionally demote
XP users off of webm or disable VP9 for us.  As this does not
occur on my win7 laptop using the same browser version. 

I updated to 43.0.1 to try to fix this (from FF42) but no.
Also tried alternate profile, disabling add-ons, toggling various
mediasource/webm options.  No luck, so this bug/issue is specific 
to "non-modern" versions of Windows (other OS's apparently MacOS 
and Linux also have sudden VP9-related playback issues, so something 
maybe changed somewhere and not been updated to account for it, 
or intentional loss of functionality imposed)

Naturally they've found a way to allow XP users to view HD content
via their own browser though, as Chrome works.  Win7+ works.  Just
XP under Firefox (and possibly other OS's).  Not sure about Vista
either, as their "missing options" page specifically cites Firefox
support being Windows 7 and above.  May be something that needs
addressed to Youtube by Mozilla.

Additionally, the media.fragmented-mp4.gmp.enabled config breaks
Youtube html5 playback altogether on Firefox/XP and was only able
to get even 360p by setting this to false, as mentioned by someone
on reddit.  As false was likely the default (?) anyhow not filing this
as a bug as probably unrelated.

Comment 5

3 years ago
Update

VP9 (480,720,etc)is available on Youtube html5 under XP
via Nightly 46.    So...not sure what that means.

Actually it probably means Youtube just isn't checking
for FF versions that far forward perhaps.  Or something
different in 42/43's configs compared to 46.  Havent't
tried the dev.44 branch yet though.
(In reply to marcus from comment #5)
> Update
> 
> VP9 (480,720,etc)is available on Youtube html5 under XP
> via Nightly 46.    So...not sure what that means.
> 
> Actually it probably means Youtube just isn't checking
> for FF versions that far forward perhaps.  Or something
> different in 42/43's configs compared to 46.  Havent't
> tried the dev.44 branch yet though.

It appears that YouTube isn't serving MSE/VP9 to 43 users for some reasons...

What about if you change the user agent to look like chrome?
create the preference in about:config
general.useragent.override set it to "Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2228.0 Safari/537.36"

Then try it with "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:44.0) Gecko/20100101 Firefox/44.0"

You can find the history about YouTube deciding to feed firefox users with low-resolution VP8 instead of flash in bug 1217170

I can confirm that setting my user agent to "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:43.0) Gecko/20100101 Firefox/43.0" and YouTube will only load mp4/h264 even if webm MSE preference is set to true
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1233970

Comment 8

3 years ago
(In reply to Jean-Yves Avenard [:jya] from comment #6)
> It appears that YouTube isn't serving MSE/VP9 to 43 users for some reasons...
> 
> What about if you change the user agent to look like chrome?
> create the preference in about:config
> general.useragent.override set it to "Mozilla/5.0 (Windows NT 6.1)
> AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2228.0 Safari/537.36"
> 
> Then try it with "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:44.0)
> Gecko/20100101 Firefox/44.0"
> 
> You can find the history about YouTube deciding to feed firefox users with
> low-resolution VP8 instead of flash in bug 1217170
> I can confirm that setting my user agent to "Mozilla/5.0 (Macintosh; Intel
> Mac OS X 10.11; rv:43.0) Gecko/20100101 Firefox/43.0" and YouTube will only
> load mp4/h264 even if webm MSE preference is set to true

Confirmed.  Works with both useragent strings you provided but not 
the default FF43,42 ones.

Man, thats underhanded.  I mean they own it I guess they can opt
to support what browsers they wish, but really, if the functionality
is supported in the software they shouldn't forcibly downgrade user
experience.

As said in my first reply to the thread, FF42 -was- serving VP9
correctly until a couple days ago.  Even videos I'd already 
watched in 720p were 360p all of a sudden.

Anyhow, I'll use the MacOS useragent for now on my desktop as 
the Chrome one produces some odd artifacts since YT is expecting 
to draw things differently probably for Chrome.  But hardly a permanent
solution for most FF users as most won't hunt bugzilla and reddit
for workarounds, and incorrect browser identification may cause
other issues on random sites.   Luckily this doesn't impact my
laptop or I'd really be ripping mad.
(Reporter)

Updated

2 years ago
Flags: needinfo?(wip.the.gruik)
You need to log in before you can comment on or make changes to this bug.