[LDAP] Allow LDAP protocol version to be specified in prefs

VERIFIED DUPLICATE of bug 198168

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
enhancement
VERIFIED DUPLICATE of bug 198168
19 years ago
13 years ago

People

(Reporter: Phil Peterson, Unassigned)

Tracking

(Blocks: 1 bug, {helpwanted})

Trunk
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
In Communicator 4.x, we apparently always bind to the directory server using
LDAPv2. We should probably bind using LDAPv3, especially since we use some v3
features. Seems like we should add some preferences like this:

ldap_2.hostname.protocolVersion, 3
ldap_2.hostname.protocolVersionFallback, true

Where the protocolVersion pref gives the number we bind as, e.g. LDAPv2, LDAPv3,
etc. The protocolVersionFallback would control what we do when binding using
protocolVersion fails: true for fall back to the previous rev, or false for the
connection to fail out with an error message.

The technote:
http://warp/server/directory-server/clientsdk/hammerhead/technotes/version-detec
t.html explains how to bind to the LDAP server using a particular protocol
version.
(Reporter)

Updated

19 years ago
Target Milestone: M15
(Reporter)

Updated

19 years ago
Status: NEW → ASSIGNED
(Reporter)

Updated

19 years ago
Severity: normal → enhancement

Updated

18 years ago
QA Contact: lchiang → pmock

Comment 1

18 years ago
changing QA assigned to pmock@netscape.com

Comment 2

18 years ago
Phil found a way to weasel out of owning this bug.  Reassigning.
Assignee: phil → selmer
Status: ASSIGNED → NEW

Comment 3

18 years ago
Mass moving to M16 to get these off the M15 radar.  Please let me know if this
is really an M15 stopper.
Target Milestone: M15 → M16

Comment 4

18 years ago
[LDAP] in summary
Summary: RFE: Allow LDAP protocol version to be specified in prefs → [LDAP] Allow LDAP protocol version to be specified in prefs

Comment 5

18 years ago
LDAP to M30, nobody, helpwanted
Assignee: selmer → nobody
Keywords: helpwanted
Target Milestone: M16 → M30

Updated

17 years ago
Blocks: 36557

Updated

17 years ago
QA Contact: pmock → hong
is this bug still relevant with more recent software versions? (bug cleaning)

Comment 7

14 years ago

*** This bug has been marked as a duplicate of 198168 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.