Closed Bug 1233638 Opened 4 years ago Closed 4 years ago

CCTOO 3.9 add-on crashes Firefox 43.0

Categories

(Firefox :: Extension Compatibility, defect, critical)

43 Branch
Unspecified
Windows
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1229493

People

(Reporter: s2and, Unassigned)

References

()

Details

(Keywords: crash, regression)

Crash Data

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36

Steps to reproduce:

I tried to use my old add-on (https://addons.mozilla.org/en-US/firefox/addon/cctoo/) - it had worked just perfectly until Firefox (Release) updated itself to 43.0. Tried to reinstall add-on - doesn't help.


Actual results:

Firefox crashes each time I try to start my add-on (click on toolbar button).


Expected results:

It should open the add-on panel as it used to on prior Firefox version.
OS: Unspecified → Windows
(In reply to Alexander from comment #0)
> Firefox crashes each time I try to start my add-on (click on toolbar button).

Please submit the crash report, then post the respective report ID from about:crashes in a comment here.
https://developer.mozilla.org/docs/How_to_get_a_stacktrace_for_a_bug_report

> it had worked just perfectly until Firefox (Release) updated itself to 43.0.

If you could find the regression range, that would help.
http://mozilla.github.io/mozregression/
Severity: normal → critical
Has Regression Range: --- → no
Component: Untriaged → Extension Compatibility
Flags: needinfo?(s2and)
Keywords: crash, regression
Summary: Add-on crashes Firefox → CCTOO 3.9 add-on crashes Firefox 43.0
Report ID: 256abbf3-4956-4b63-8bd9-202302151218
Flags: needinfo?(s2and)
Status: UNCONFIRMED → NEW
Crash Signature: [@ JSCompartment::wrap ]
Ever confirmed: true
Narrowed nightly regression window from [2015-08-24, 2015-08-26] (2 days) to [2015-08-24, 2015-08-25] (1 days) (~0 steps left)


Looks works in Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0 ID:20151217072309 CSet: 0711218a018d912036f7d3be2ae2649e213cfb85.

Looks fixed in bug 1229493.
Depends on: 1229493
Yes, it's a dupe and fixed.
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=48f854ba48c09b38b05208ce8513cbc452af35fc&tochange=801a1141bc38e8c36a3ba1fdad4f1bf81fd73a5f
Status: NEW → RESOLVED
Closed: 4 years ago
No longer depends on: 1229493
Resolution: --- → DUPLICATE
Duplicate of bug: 1229493
Has Regression Range: no → yes
You need to log in before you can comment on or make changes to this bug.