Closed Bug 1233710 Opened 6 years ago Closed 6 years ago

Unable to make api calls

Categories

(Websites :: wiki.mozilla.org, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: vciobancai, Unassigned)

Details

I'm a part of buildduty team and we have some bash scripts that are using wiki api in order to edit a wiki page. I would like to mention if I editing the page via browser is working.

There is some extra permissions for a user to edit a wiki page from wiki api ? My account is Vlad.ciobancai and e-mail adress is vlad.ciobancai@softvision.ro
No special permissions are needed to use the api. If you can edit pages via the web interface, you should be able to via the api with same user credentials.

One issue we've encountered with those bash scripts is that they sometimes fail with wiki passwords that have special characters (I forget which). Try checking your wiki password for any characters that bash might have an issue with?
Flags: needinfo?(vlad.ciobancai)
In my password I had some special characters( for example: !)but I changed the password to use only lower words and still not working.

I have another question, should be my username a problem ? because the username contains a dot or begin with a higher word (V)
Flags: needinfo?(vlad.ciobancai)
:ckoehler I would like to ask you if it's possible that my username can be changed to vladC or other username that not contain dot in name
Flags: needinfo?(ck)
I just changed Vlad's username to vladC(https://wiki.mozilla.org/User:VladC). Let's see if it works!
Flags: needinfo?(ck)
(In reply to Captain Calliope from comment #4)
> I just changed Vlad's username to
> vladC(https://wiki.mozilla.org/User:VladC). Let's see if it works!

Thank you. The wiki api works now, the problem was the curl command was not installed
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.