Closed Bug 1233829 Opened 5 years ago Closed 5 years ago

thunderbird builds can't generate info from application.ini because of printconfigsetting.py invocation

Categories

(Release Engineering :: Release Automation: Other, defect)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1233577

People

(Reporter: jlund, Unassigned)

References

Details

Attachments

(1 file)

history time!

1. build sys got rid of config/configobj.py from gecko recently: Bug 957911 - Remove config/configobj.py

2. which meant that we had to change how we invoked printconfigsetting.py in our mozharness automation: Bug 957951 - Use mach to invoke printconfigsetting.py

3. we forgot to change buildbot automation however which was still the primary place for building TB everywhere and for FF on beta/release/esr. So TB fixed this first: Bug 1213715 - TB needs changes to how it gets the app version and buildid via printconfigsettings.py(for bug 957911)

4. but then we had to fix FF once (1) landed on beta: Bug 1232466 - beta CI builds fail trying to use printconfigsetting.py and running prettyname targets for package and update when GTK+3 is enabled


5. that fix in (4) was supposed to be a unified way to fix it for all the things, TB included but it's not quite right:

job (platform wide): http://buildbot-master91.bb.releng.usw2.mozilla.com:8001/builders/release-comm-beta-linux_build/builds/2

log:
/tools/buildbot/bin/python /builds/slave/tb-rel-c-beta-lx_bld-000000000/build/mach python /builds/slave/tb-rel-c-beta-lx_bld-000000000/build/mozilla/config/printconfigsetting.py /builds/slave/tb-rel-c-beta-lx_bld-000000000/build/objdir-tb/dist/bin/application.ini App BuildID
 in dir /builds/slave/tb-rel-c-beta-lx_bld-000000000/build/objdir-tb (timeout 1200 secs)
/tools/buildbot/bin/python: can't open file '/builds/slave/tb-rel-c-beta-lx_bld-000000000/build/mach': [Errno 2] No such file or directory

My guess is we are looking for mach in the comm repo and not gecko repo. Need a special case for TB in our automation...
I suppose as an option, we could just re-open https://bugzilla.mozilla.org/show_bug.cgi?id=1213715

but I'll leave this open in case we want to clearly highlight the history from comment 0
Summary: thunderbird builds can't generate info form application.ini because of printconfigsetting.py invocation → thunderbird builds can't generate info from application.ini because of printconfigsetting.py invocation
I have no idea if this patch is correct, or if it works. It is *completely* untested. And before landing we should try and make sure that even calling mach for TB here "works" as well as make sure this patch passes checkconfig in buildbot.

Still flagging for review though.

Additionally a dump of the config would be useful to verify we don't change the string used for non TB builds here.
Attachment #8700263 - Flags: review?(jlund)
Thanks all.

I haven't made this critical or blocker so that people don't get paged - but it is that important to get resolved quickly, so that we get our builds done in time for SHA2, etc
Severity: normal → major
Looks like a duplicate of bug 1233577?
Comment on attachment 8700263 [details] [diff] [review]
[custom] untested fix to call mach at the right place

Obsoleted by Bug 1233577
Attachment #8700263 - Flags: review?(jlund)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1233577
You need to log in before you can comment on or make changes to this bug.