Last Comment Bug 1233878 - tracking flags don't show up in the view of the bug right after filing
: tracking flags don't show up in the view of the bug right after filing
Status: RESOLVED FIXED
:
Product: bugzilla.mozilla.org
Classification: Other
Component: Extensions: TrackingFlags (show other bugs)
: Production
: Unspecified Unspecified
-- normal (vote)
: ---
Assigned To: Dylan Hardison [:dylan]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 15:44 PST by David Baron :dbaron: ⌚️UTC-8
Modified: 2016-01-04 13:35 PST (History)
3 users (show)
See Also:
Due Date:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
1233878_2.patch (847 bytes, patch)
2015-12-30 09:38 PST, Dylan Hardison [:dylan]
dkl: review+
Details | Diff | Splinter Review

Description User image David Baron :dbaron: ⌚️UTC-8 2015-12-18 15:44:52 PST
I just filed bug 1233873, and then realized that I wanted to nominate it for tracking46.  I was looking at the view of the bug that showed up right after I submitted it, and I couldn't find where to do this.

Then when I reloaded the bug by clicking on the bug number link, the UI (the "Firefox Tracking Flags" section) showed up.

The tracking flags should show up in all views of the bug rather than being mysteriously missing (and confusing me as to where they are in the new UI) in some views of the UI.

I'm using the new UI (i.e., "Use experimental user interface": "On" in https://bugzilla.mozilla.org/userprefs.cgi?tab=settings ).
Comment 1 User image Dylan Hardison [:dylan] 2015-12-18 16:05:30 PST
Bug confirmed. It looks like the modal template does not recognize the firefox-ness of newly filed bugs.
Comment 2 User image Tony Mechelynck [:tonymec]. (NEEDINFO me if you want my attention) 2015-12-20 19:43:31 PST
That new experimental UI is weird. I can see the tracking flags but not change them (e.g., there's no way I could set "seamonkey-2.42: affected" on bug 1233744); also, the INCOMPLETE and WORKSFORME resolutions seem to have disappeared. (I have editbugs and I tried while logged-in.) The latter is of course a different bug.
Comment 3 User image Tony Mechelynck [:tonymec]. (NEEDINFO me if you want my attention) 2015-12-20 19:51:33 PST
oops, 2.43: affected
Comment 4 User image Tony Mechelynck [:tonymec]. (NEEDINFO me if you want my attention) 2015-12-20 19:55:16 PST
ah, sorry: to change anything in the bug header I have to first click "Edit" near top right. Score 1 against discoverability.
Comment 5 User image Dylan Hardison [:dylan] 2015-12-29 05:29:57 PST
Update: I think that $vars->{tracking_flags} is getting overriden by later calls to the template_before_process extension hook.
Thus it ends up being empty on any edit view coming from process_bug.cgi.

Should have a fix on this today.
Comment 6 User image Dylan Hardison [:dylan] 2015-12-30 09:38:03 PST
Created attachment 8702938 [details] [diff] [review]
1233878_2.patch

It's a bit hard to tell if this is working, as tracking flags are a bit wonky on my local system. But I think this is right.
Comment 7 User image David Lawrence [:dkl] 2016-01-04 13:08:21 PST
Comment on attachment 8702938 [details] [diff] [review]
1233878_2.patch

Review of attachment 8702938 [details] [diff] [review]:
-----------------------------------------------------------------

r=dkl
Comment 8 User image Dylan Hardison [:dylan] 2016-01-04 13:35:18 PST
To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   16176cb..efe494e  master -> master

Note You need to log in before you can comment on or make changes to this bug.