Buttons and menu items will highlight but not function when tapped if the user is also touching the SHB bar.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED WONTFIX
3 years ago
4 months ago

People

(Reporter: Marty, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-v2.5 affected, b2g-master affected)

Details

(Whiteboard: [2.6-Daily-Testing][Spark], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8700223 [details]
logcat_SHB-touch.txt

Description:
If the user is touching the Software Home Button bar (but not the button itself), and they tap a menu list item or a button, that item will highlight but not function.

This occurs in the device FTU, the Usage FTU, bluetooth pairing pop-ups, and list items in the Settings menus.

Repro Steps:
1) Update a Aries to 20151218153622
2) Open the Settings app
3) Touch the side of the black SHB bar.
4) With another finger, try to tap on the list items of the Settings app.

Actual:
Buttons and menu items will highlight but not function when tapped if the user is also touching the SHB bar.

Expected:
Buttons and menu items only highlight if they are selectable and function properly.

Environmental Variables:
Device: Aries 2.6
Build ID: 20151218153622
Gaia: d069027f9af6f835ef869f1f01b52339e5a3f423
Gecko: c5cb194cc9cb56d742fb3a7a826f0080b0404edc
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 46.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

Repro frequency: 4/5
See attached: Video (URL), Logcat
(Reporter)

Comment 1

3 years ago
This issue DOES occur on the latest Flame 2.6, 2.5, and 2.2 builds.
Buttons and menu items will highlight but not function when tapped if the user is also touching the SHB bar.

Environmental Variables:
Device: Flame 2.6
BuildID: 20151218030236
Gaia: 2f093462969d2c5f65dced3908a7abff6b1913e8
Gecko: 66fb852962c0d5f6f5fe0604204da4f5d17763c9
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 46.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

Environmental Variables:
Device: Flame 2.5
BuildID: 20151218180935
Gaia: eeed1451e0e48b63abe3199e4d6906adc2a762d2
Gecko: 766600655dfb1b67c380b9da4f4b19acb505a858
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20151218032501
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: 2120b3e6f680
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
I also noticed this on the homescreen. You can open apps when you also touch the SHB bar but you can't open pinned pages on the 2nd homescreen panel. kats, any idea if this is a platform limitation or if we need to fix this in gaia?
Flags: needinfo?(bugmail.mozilla)
If I'm understanding correctly, the problem is that items highlight even though they are not clickable, because the user already has a finger down somewhere else. So this probably needs the UX spec for active states (bug 1009684) to be done first.
Depends on: 1009685
Flags: needinfo?(bugmail.mozilla)
Depends on: 1009684
No longer depends on: 1009685
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Comment 4

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.