Closed Bug 1234130 Opened 4 years ago Closed 4 years ago

MSVC linker warning LNK4217: locally defined symbol Hunspell::Hunspell() imported in function mozHunspell::SetDictionary()

Categories

(Core :: Spelling checker, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla47
Tracking Status
firefox46 --- affected
firefox47 --- fixed

People

(Reporter: cpeterson, Assigned: glandium)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

mozHunspell.obj : warning LNK4217: locally defined symbol ??0Hunspell@@QAE@PBD00@Z (public: __thiscall Hunspell::Hunspell(char const *,char const *,char const *)) imported in function "public: virtual enum nsresult __stdcall mozHunspell::SetDictionary(wchar_t const *)" (?SetDictionary@mozHunspell@@UAG?AW4nsresult@@PB_W@Z)
mozHunspell.obj : warning LNK4217: locally defined symbol ??1Hunspell@@QAE@XZ (public: __thiscall Hunspell::~Hunspell(void)) imported in function "protected: virtual __thiscall mozHunspell::~mozHunspell(void)" (??1mozHunspell@@MAE@XZ)
mozHunspell.obj : warning LNK4217: locally defined symbol ?spell@Hunspell@@QAEHPBDPAHPAPAD@Z (public: int __thiscall Hunspell::spell(char const *,int *,char * *)) imported in function "public: virtual enum nsresult __stdcall mozHunspell::Check(wchar_t const *,bool *)" (?Check@mozHunspell@@UAG?AW4nsresult@@PB_WPA_N@Z)
mozHunspell.obj : warning LNK4217: locally defined symbol ?suggest@Hunspell@@QAEHPAPAPADPBD@Z (public: int __thiscall Hunspell::suggest(char * * *,char const *)) imported in function "public: virtual enum nsresult __stdcall mozHunspell::Suggest(wchar_t const *,wchar_t * * *,unsigned int *)" (?Suggest@mozHunspell@@UAG?AW4nsresult@@PB_WPAPAPA_WPAI@Z)
mozHunspell.obj : warning LNK4217: locally defined symbol ?get_dic_encoding@Hunspell@@QAEPADXZ (public: char * __thiscall Hunspell::get_dic_encoding(void)) imported in function "public: virtual enum nsresult __stdcall mozHunspell::SetDictionary(wchar_t const *)" (?SetDictionary@mozHunspell@@UAG?AW4nsresult@@PB_W@Z)
This was caused by bug 1200065.
https://hg.mozilla.org/releases/mozilla-aurora/rev/04b17a8de4ed

These warnings are a little annoying, so it would be good to fix the issue or shut up the warning.

I tried to make some sense if it but only found some very MS specific information:
https://msdn.microsoft.com/en-us/library/aa3se25k%28v=vs.120%29.aspx
http://stackoverflow.com/questions/6979491/how-to-delete-warnings-lnk4217-and-lnk4049
Flags: needinfo?(sajitk)
Flags: needinfo?(mh+mozilla)
Hardware: Unspecified → x86
Version: unspecified → Trunk
DEFINES['HUNSPELL_STATIC'] = True needs to be added to extensions/spellcheck/hunspell/glue/moz.build
Flags: needinfo?(mh+mozilla)
Assignee: nobody → mh+mozilla
Attachment #8711944 - Flags: review?(mshal)
Great! Thank you so much.
Comment on attachment 8711944 [details] [diff] [review]
Fix MSVC LNK4217 warning in hunspell

Solves the problem for me.
Attachment #8711944 - Flags: feedback+
Attachment #8711944 - Flags: review?(mshal) → review+
Flags: needinfo?(sajitk)
https://hg.mozilla.org/mozilla-central/rev/a09bdadea91c
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
You need to log in before you can comment on or make changes to this bug.