Closed Bug 1234205 Opened 5 years ago Closed 5 years ago

Synced tabs icon needs inverted variant for menuPanel

Categories

(Firefox :: Sync, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 47
Tracking Status
firefox45 --- affected
firefox46 --- affected
firefox47 --- verified

People

(Reporter: ntim, Assigned: markh)

References

Details

Attachments

(2 files, 2 obsolete files)

When the subview is opened, the icon should turn white.
Depends on: 1239084
Ryan, can you confirm this behavior? I don't see other icons in the toolbar turn white after they open a submenu.
No longer depends on: 1239084
Flags: needinfo?(rfeeley)
Flags: firefox-backlog+
Priority: -- → P3
(In reply to Chris Karlof [:ckarlof] from comment #1)
> Ryan, can you confirm this behavior? I don't see other icons in the toolbar
> turn white after they open a submenu.

This is about buttons inside the menu-panel. In the menu-panel, if you open the history subview, you can see the history icon turns white.
Attached image inverted.png (obsolete) —
Inverted Synced Tabs icon? A picture is worth a few comments in this case. Attached. I am pretty sure it is either Stephen or Bryan that have the finished assets for this icon. One of them can provide.
Flags: needinfo?(shorlander)
Flags: needinfo?(rfeeley)
Flags: needinfo?(bbell)
> This is about buttons inside the menu-panel. In the menu-panel, if you open the history subview, you can see the history icon turns white.

Indeed. I can reproduce in Nightly 20160119030232.
Blocks: 1239084
Attached file MenuPanel.zip (obsolete) —
Here are the assets you need for Mac, Windows and Linux.
Attachment #8708840 - Attachment is obsolete: true
Flags: needinfo?(shorlander)
Flags: needinfo?(bbell)
Assignee: nobody → markh
Bryan,
  It looks like these need to be crushed or optimized, or whatever it is you do :) The files are all significantly bigger:

 browser/themes/linux/menuPanel.png           | Bin 18621 -> 25617 bytes
 browser/themes/linux/menuPanel@2x.png        | Bin 43286 -> 57179 bytes
 browser/themes/osx/menuPanel-yosemite.png    | Bin 24167 -> 37678 bytes
 browser/themes/osx/menuPanel-yosemite@2x.png | Bin 57442 -> 84530 bytes
 browser/themes/osx/menuPanel.png             | Bin 32184 -> 50900 bytes
 browser/themes/osx/menuPanel@2x.png          | Bin 74263 -> 113265 bytes
 browser/themes/windows/menuPanel-aero.png    | Bin 35835 -> 53251 bytes
 browser/themes/windows/menuPanel-aero@2x.png | Bin 95608 -> 130906 bytes
 browser/themes/windows/menuPanel.png         | Bin 18114 -> 25617 bytes
 browser/themes/windows/menuPanel@2x.png      | Bin 41158 -> 57179 bytes
 
and I don't think the increased sizes can be explained by just that extra inverted icon.
Flags: needinfo?(bbell)
I've optimised them using kraken.io lossless optimiser.
Attachment #8718149 - Attachment is obsolete: true
Flags: needinfo?(bbell)
(In reply to Tim Nguyen [:ntim] from comment #7)
> Created attachment 8721205 [details]
> menupanel-optimised.zip
> 
> I've optimised them using kraken.io lossless optimiser.

thanks
Comment on attachment 8721821 [details] [diff] [review]
0001-Bug-1234205-add-an-inverted-version-of-the-synced-ta.patch

Review of attachment 8721821 [details] [diff] [review]:
-----------------------------------------------------------------

rubberstamping the images, I'm going to assume they work. The CSS looks great. Sorry for not spotting this in the initial patch. :-\
Attachment #8721821 - Flags: review?(gijskruitbosch+bugs) → review+
Thanks - the sheriffs will hopefully beat me to the checkins!
Keywords: checkin-needed
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/1eefe1efe183
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
Flags: qe-verify+
I was able to reproduce this issue on Firefox 46.0a1 (2016-01-08) using Windows 10 64-bit.

Verified fixed on Firefox 47.0a1 (2016-02-28) under Windows 10 64-bit, Ubuntu 12.04 32-bit and Mac OS X 10.11. The Synced tabs icon is successfully turned to white when the synced panel is opened.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.