`mach test` spends about 30 seconds scanning for changed tests ("From _tests: Kept ...") before running requested test

RESOLVED DUPLICATE of bug 1234728

Status

RESOLVED DUPLICATE of bug 1234728
3 years ago
9 months ago

People

(Reporter: jaws, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

We spend a huge amount of time on each test run looking for changed tests.

On my local machine, if I run:
`time mach mochitest browser/components/preferences/in-content/tests/browser_subdialog.js --e10s` I get the following output:

mach says that the command took 15 seconds
time says that the command took 1m8s

This, and visually watching console output, is telling me that the setup time for mach test is taking up a lot of time (potentially >45s!).

Gregory told me that this was on a roadmap for Q1 2016 to get fixed, but said that there wasn't a bug on file for it yet. Filing now to make sure this doesn't get forgotten.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1234728

Updated

9 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.