If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

downloads fail in firefox 43 for some linux users in safe mode too

RESOLVED DUPLICATE of bug 1233434

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1233434
2 years ago
2 years ago

People

(Reporter: iii_iii, Unassigned)

Tracking

43 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 2015121300

Steps to reproduce:

Tried to download this

http://cdimage.debian.org/debian-cd/8.2.0/i386/iso-cd/debian-8.2.0-i386-netinst.iso

By clicking the 386 link here:

https://www.debian.org/distrib/netinst#smallcd

This affects all downloads even with a new profile in safe mode, however switching to a different linux user does not fail.

The problem has also been reported elsewhere.

https://bbs.archlinux.org/viewtopic.php?id=206506

https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1527884




Actual results:

The download appears as failed. It fails instantly and does not ask where to download.

The jsconsole reports:

[Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIAnnotationService.setPageAnnotation]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: resource://app/modules/DownloadsCommon.jsm :: onDownloadChanged :: line 735"  data: no]



Expected results:

Should have downloaded
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

2 years ago
Built from http://hg.mozilla.org/releases/mozilla-release/rev/fc05d86dc310

opensuse build service.

Comment 2

2 years ago
Maybe Bug 1233434
(Reporter)

Comment 3

2 years ago
(In reply to Alice0775 White from comment #2)
> Maybe Bug 1233434

I am not sure. For me it is always the same user who cannot download. However I will try setting TMP.
(Reporter)

Comment 4

2 years ago
Setting TMP didn't work, but there was a directory in /tmp called mozilla_mozillaUser0 and when I deleted it, the problem went away. So I guess it is a duplicate.
(Reporter)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1233434
You need to log in before you can comment on or make changes to this bug.