43.0.1 stub installer fails while "Downloading Firefox" on Windows XP

RESOLVED FIXED

Status

()

Firefox
Installer
--
critical
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: jpetto, Unassigned)

Tracking

43 Branch
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox43+ affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8701533 [details]
Screen Shot 2015-12-23 at 11.32.33 AM.png

OS: Windows XP SP2 & SP3
Locale: en-US

STR: Visit www.mozilla.org, click any of the download buttons. Should get "Firefox Setup Stub 43.0.1.exe" (see bug 1233779). Run stub installer. About 70% of the way through "Downloading Firefox..." should see "Your download was interrupted" error dialog.

Clicking "OK" in the error dialog opens installer help page [1], where you can download the full installer. The full installer successfully installs Firefox.

Stub installer failed on 5/5 manual tests. 

[1] https://www.mozilla.org/en-US/firefox/installer-help/?channel=release&installer_lang=en-US

Updated

2 years ago
Severity: normal → critical
Confirming the same behavior on a separate Windows XPsp2 VM (a completely different installation, mind you, not a copy of the same VM). Stub installer begins to run then fails with a "Download interrupted" error.
This sounds like the result of 43.0.1[1] & 43.0.2[2] stub installers share the same bouncer url for full installer, while there's no "Windows NT 5.1" etc. in UA of InetBgDL component[3][4] for the request from 43.0.1 stub installer to be redirected to 43.0.1 instead of latest full installer.

[1]: https://hg.mozilla.org/releases/mozilla-release/file/FIREFOX_43_0_1_RELEASE/browser/branding/official/branding.nsi#l21
[2]: https://hg.mozilla.org/releases/mozilla-release/file/FIREFOX_43_0_2_RELEASE/browser/branding/official/branding.nsi#l21
[3]: https://hg.mozilla.org/releases/mozilla-release/file/FIREFOX_43_0_1_RELEASE/other-licenses/nsis/Contrib/InetBgDL/InetBgDL.cpp#l7
[4]: https://hg.mozilla.org/releases/mozilla-release/file/FIREFOX_43_0_2_RELEASE/other-licenses/nsis/Contrib/InetBgDL/InetBgDL.cpp#l7
Flags: needinfo?(robert.strong.bugs)
XP SP2 Users shouldn't be given a link to download the stub installer from our web properties.
Flags: needinfo?(robert.strong.bugs)

Comment 4

2 years ago
Created attachment 8701749 [details] [review]
Bouncer PR 18
Blocks: 1079858
status-firefox43: --- → affected
tracking-firefox43: --- → +
(In reply to Josh Mize [:jgmize] from comment #4)
> Created attachment 8701749 [details] [review]
> Bouncer PR 18

Josh, do you you know if the PR has been deployed yet?
Flags: needinfo?(jmize)
Sounds like this is still on stage but not production. 
sphilp or mbrandt, can you test it there before we deploy it? Thanks.
Flags: needinfo?(sphilp)
Flags: needinfo?(mbrandt)

Comment 7

2 years ago
The deployment is being tracked on bug 1235440.
Flags: needinfo?(jmize)
(In reply to Josh Mize [:jgmize] from comment #7)
> The deployment is being tracked on bug 1235440.

thanks!
Depends on: 1235440
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #6)
> Sounds like this is still on stage but not production. 
> sphilp or mbrandt, can you test it there before we deploy it? Thanks.

Bug 1235440 has been verified on stage.
Flags: needinfo?(sphilp)
Flags: needinfo?(mbrandt)
Matt did you also test for XP?  Since this deployment looks like it has changes so that both XP and Vista users don't get the stub installer but instead get redirected to get 43.0.1 .
Flags: needinfo?(mbrandt)
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #10)
> Matt did you also test for XP? 
Verified on stage - WinXP users (x32 & x64) - the stub alias redirects to 43.0.1 as well.
Flags: needinfo?(mbrandt)
I have an XP machine that reproduces this if anybody needs this verified.  Incidentally, this is also failing for 44 beta for me.
Jeremy can you check that there are rules for the stub installers for XP (and vista I believe) for beta, aurora, and nightly as well?
Flags: needinfo?(oremj)
The rules are in place for beta. We don't have any rules for aurora or nightly.

Aurora only has one "product", so it's not possible to pin it to an earlier release. Nightly is served directly from archive.mozilla.org, linked from nightly.mozilla.org.
Flags: needinfo?(oremj)
Thanks Jeremy. Milan, I'm not sure why beta is failing for you then.  
Matt can you take a look to see if the beta XP updater works as we expect it should?
Flags: needinfo?(mhowell)
It looks like Milan commented (10am) before the fix was deployed (3pm). Milan, can you verify that it is working now?
Flags: needinfo?(milan)
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #15)
> Thanks Jeremy. Milan, I'm not sure why beta is failing for you then.  
> Matt can you take a look to see if the beta XP updater works as we expect it
> should?

On XP (SP2) the main download page for release goes to the full installer for 43.0.1, which works fine, and then I get offered an update to 43.0.4, which succeeds. The beta download page does the same with 44.0b1 and updates to 44.0b8. I'd say things look good.
Flags: needinfo?(mhowell)
(In reply to Jeremy Orem [:oremj] from comment #16)
> It looks like Milan commented (10am) before the fix was deployed (3pm).
> Milan, can you verify that it is working now?

I will test this tomorrow, I don't have access to that computer today.
I couldn't get to the stub installer, it seems that the default was to have the "Download" button give me the full one instead.  So, as far as the overall experience goes, it worked, but I can't verify that the stub installer itself is working properly.
Flags: needinfo?(milan)

Updated

2 years ago
See Also: → bug 1239685
Is this still an issue or is it fixed? I think it was cleared up from changes in another bug. 
Cornel can you or someone on your team make sure we're ok with the stub installer for XP? Thanks.
Flags: needinfo?(cornel.ionce)
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #20)
> Is this still an issue or is it fixed? I think it was cleared up from
> changes in another bug. 

The stub installer itself will no longer work for a large percentage of XP & Vista users, but the change to bouncer that was deployed in bug 1235440 redirects all XP and Vista users to the full installer for 43.0.1 (the last release version signed with SHA-1), so users are no longer seeing the issue.
As Josh mentioned in the above comment, the users will now download the full installer of 43.0.1 instead of the stub installer, so this issue cannot be reproduced now.

Verified on Windows XP x64 and Vista x86 and the full installer is downloaded on both OSs.
Flags: needinfo?(cornel.ionce)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.