43.0.2 stub installer will not open when attempting to run from disk on Windows Vista

RESOLVED FIXED

Status

()

Firefox
Installer
--
critical
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: jpetto, Unassigned)

Tracking

43 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(firefox43+ affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8701543 [details]
vista-stub-issue.mp4

OS: Windows Vista
STR: Visit www.mozilla.org and click any download button. When file dialog appears, choose "Save". Attempt to open saved stub installer [1]. Nothing happens.

Choosing "Run" from the file save dialog successfully starts the installer.

Saving the 43.0.1 stub installer [2] and running from disk successfully starts the installer.


[1] https://download-installer.cdn.mozilla.net/pub/firefox/releases/43.0.2/win32/en-US/Firefox%20Setup%20Stub%2043.0.2.exe
[2] https://download-installer.cdn.mozilla.net/pub/firefox/releases/43.0.1/win32/en-US/Firefox%20Setup%20Stub%2043.0.1.exe
Confirming the same behavior in another Vista VM. Thus far we've been able to reproduce this using the stock Vista VMs provided by modern.ie, but ideally we should confirm this bug with a different setup just to be sure it's not an issue with the particular VM they distribute.

Comment 2

2 years ago
We should consider expanding the changes to bouncer made for bug 1233779 to include Vista as well due to this issue.
Probably, Jeremy, can you help here? Thanks
Flags: needinfo?(oremj)

Comment 4

2 years ago
I believe https://support.microsoft.com/en-us/kb/2763674 is the likely culprit here.

Comment 5

2 years ago
It looks like Vista is Windows NT 6.0. It would be easy to add this to bouncer. Let's plan on doing this. Should we do an emergency push today or wait until after the holiday weekend?
Flags: needinfo?(oremj)

Comment 6

2 years ago
Shall we start pinning Vista to sha1 builds as well?
Yes, thank you Jeremy, please do! Again, I guess our issue is that we can't differentiate easily between Vista users who have service pack 2 vs. those who don't. So for now we have to send them all to the sha-1 builds.
status-firefox43: --- → affected
tracking-firefox43: --- → +
Blocks: 1079858
Jeremy, can you take this? I think it may be the last issue we have to deploy.
Flags: needinfo?(oremj)

Comment 9

2 years ago
The work around has been deployed.
Flags: needinfo?(oremj)

Updated

a year ago
See Also: → bug 1240511
(In reply to Jeremy Orem [:oremj] from comment #9)
> The work around has been deployed.

Closing.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.