Closed Bug 1235253 Opened 7 years ago Closed 5 years ago

Cannot click on dynamical links on site ugc.fr when tracking protection is on

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: eric.brunet, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: tp-base)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151210112434

Steps to reproduce:

With 

 Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0

on my fedora 23 linux machine, I am trying to book a movie on the french cinema site ugc.fr. Go to ugc.fr and pick a movie; for instance I pick "star wars" and was sent to

http://www.ugc.fr/film.html?id=10772

On this page, there is a photo of the film and on the right a list of showings on all the ugc movie theaters, and some filters such as "2D" or "3D". One should be able to pick a showing on the list by clicking on a time, but it does not work: nothing happens. Similarly, clicking on "2D" or "3D" or other filters does nothing. Choosing a different date or a specific movie theater in the menu does not work as well.

This is a regression: going through the same steps on an old fedora 21 computer with

Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0

gives the expected results: all the links work perfectly.
Hi Éric,

Are you using an ad blocker? By using uBlock origin for instance, links are not working, but if I disable it, links are working as expected.

Let me know if that fixes the issue on your end, so that we can close this bug.

Thanks!
Hi,

Yes I am using uBlock. Here is what I tried:

1) I tried to start firefox with a new profile. The site ugc.fr works.
2) With my normal profile, I went to the Modules menu and I desactivated there all the extensions
(including uBlock) and the one plugin I use (flash). (I don't understand the difference between a plugin and an extension, but that's not the point). I quit and restart firefox and then, the site ugc.fr is not working.

So, it seems that it is not only uBlock which is at fault, but also some other option I configured in a basic firefox. But which one ?
(In reply to Éric Brunet from comment #2)
> Hi,
> 
> Yes I am using uBlock. Here is what I tried:
> 
> 1) I tried to start firefox with a new profile. The site ugc.fr works.
> 2) With my normal profile, I went to the Modules menu and I desactivated
> there all the extensions
> (including uBlock) and the one plugin I use (flash). (I don't understand the
> difference between a plugin and an extension, but that's not the point). I
> quit and restart firefox and then, the site ugc.fr is not working.
> 
> So, it seems that it is not only uBlock which is at fault, but also some
> other option I configured in a basic firefox. But which one ?

I can only do guesses, but it is likely something related to scripts as links on ugc.fr seem to rely on Google Analytics to be working.

Have you turned off JavaScript or enabled Tracking Protection feature for regular browsing (e.g. not only in Private Browsing windows)?
Oh, you are good. After some experimentation, the site ugc.fr does not work if any of the following items is activated:
*) the extension ublock
*) the extension ghostery
*) the basic firefox setting privacy.trackingprotection.enabled

So, now I know. I thought that trackingprotection would protect me from passive tracking, but that an explicit click from the user would still be obeyed. Well, it is probably difficult.

Thanks!
François, have we considered mocking the entry points of google analytics when we block its load (and perhaps other popular tracking libraries?) in order to unbreak JS that looks like:

function doThing() {
  ga_trackAllTheThingsFirst(...);
  nowReallyDoThing();
}
Blocks: tp-breakage
Component: General → DOM: Security
Flags: needinfo?(francois)
Product: Firefox → Core
Summary: Cannot click on dynamical links on site ugc.fr → Cannot click on dynamical links on site ugc.fr when tracking protection is on
(In reply to :Gijs Kruitbosch from comment #5)
> François, have we considered mocking the entry points of google analytics
> when we block its load (and perhaps other popular tracking libraries?)

We have discussed it, but haven't implemented anything along those lines, nor made plans to shim this. If it becomes a big webcompat issue, I think we should consider it.

In the meantime, it would be good to provide an example of what not to do (and what to do instead) when using Google Analytics on https://developer.mozilla.org/en-US/Firefox/Privacy/Tracking_Protection#What_does_this_mean_for_your_website
Flags: needinfo?(francois)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: DOM: Security → Safe Browsing
Product: Core → Toolkit
Component: Safe Browsing → Tracking Protection
Product: Toolkit → Firefox
Version: 43 Branch → unspecified
Component: Tracking Protection → Desktop
Product: Firefox → Tech Evangelism
Whiteboard: tp-base
Tested on 58.0a1 with TP enabled. Original film link no longer has listings. Tested with the link below, film times display, able to switch days and select viewing times & it navigates correctly.

https://www.ugc.fr/film.html?id=11726
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.