-Moz-Binding Unset/none dosen't work

RESOLVED DUPLICATE of bug 119078

Status

()

Core
XBL
RESOLVED DUPLICATE of bug 119078
2 years ago
2 years ago

People

(Reporter: Almog Guata, Unassigned)

Tracking

43 Branch
All
Unspecified
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36

Steps to reproduce:

1. Install adblock plus extension for firefox.
2. create a page with this HTML:
<div id="aaa" class="adUnit">aaaaaaaaaaaa</div>
3. now adblock plus will create a mozBinding to this className with a broken XML which will result in "display:none".
this is the css example:
.adUnit {-moz-binding: url("abp-elemhidehit?914416608504#dummy") }
this is abp-elemhidehit?914416608504#dummy source:
<bindings xmlns='http://www.mozilla.org/xbl'/>

the result is that the element is not displayed even if it sets to display block & visibility visible.

I've tried to override the -moz-binding with inline css (which should win) like this:
<div id="aaa" class="adUnit" style="-moz-binding: none !important">aaaaaaaaaaaa</div>
but it is not working.
if you will check:
document.querySelector('aaa').style.MozBinding you will see the 'none' string I've set.
but if you will check computedStyle, you will see Adblock Plus broken MozBinding.

Nevertheless, even If I will remove the "adUnit" class from the element ClassList (which is the reason for the MozBinding effect), It won't work, the element won't appear again, never.


Actual results:

Element is not displayed, And can't be redisplayed no matter what.


Expected results:

inline style -moz-binding should win the outline css created by adblock plus extension.
(Reporter)

Updated

2 years ago
Priority: -- → P3
Hardware: Unspecified → All

Updated

2 years ago
Component: Untriaged → Untriaged
Priority: P3 → --
Product: Firefox → Core

Updated

2 years ago
Component: Untriaged → XBL
> will create a mozBinding to this className with a broken XML

No, it creates the exact binding it means to: it's treating it as an ad and hiding it.  If you think it shouldn't, please do report a bug to adblock plus.

The rest is bug 119078 and is not likely to be fixed, for what it's worth.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 119078
You need to log in before you can comment on or make changes to this bug.