Closed Bug 1235709 Opened 4 years ago Closed 4 years ago

Alert and onbeforeunload dialogs are broken on background tabs with "data:" or some "about:" urls

Categories

(Firefox :: Untriaged, defect)

defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 1233747
Tracking Status
firefox46 --- affected

People

(Reporter: arni2033, Assigned: Gijs)

References

Details

Attachments

(1 file)

>>>   My Info:   Win7_64, Nightly 46, 32bit, ID 20151223030323
STR (there're 4 scenarios - A->C, A->D, B->C, B->D):

> screencast of scenario A->C:   https://dl.dropboxusercontent.com/s/bf1ceurrvelw3xl/screencast%201%20-%20alerts.webm?dl=0
> screencast of scenario B->C:   https://dl.dropboxusercontent.com/s/pj67f6qeey1wsyu/screencast%202%20-%20onbeforeunload.webm?dl=0

 (A) - alerts
1.   Open new window (just in case)
2.C) Open "testcase 1" that window, then middle-click the link "alerts"
     to open "data:" url in a new tab
2.D) Type "about:home" in location bar, press Enter
     Open devtools -> Console, type there "setTimeout(_=>alert(2),4000)", press Enter
     Close devtools, Open new tab (you must perform this in less than 4 seconds)
3.   Wait 4 seconds
4.   Switch to "data:"/"about:" tab from Step 2

 (B) - onbeforeunload dialog
1.   Open new window (just in case)
2.C) Open "testcase 1" in that window, then middle-click the link "onbeforeunload"
     to open "data:" url in a new tab. Click that tab to swith to it.
2.D) Type "about:home" in location bar, press Enter
     Open devtools -> Console, type there "onbeforeunload=_=>1", press Enter
     Close devtools
3.   Click on the page content
4.   Open new tab
5.   Middle-click the "data:"/"about:" tab from Step 2 several times (from 1 to 5)
6.   Switch to "data:"/"about:" tab from Step 2

Result:       
 The "data:"/"about:" page from Step 2 displays empty confirm dialog

Expectations: 
 (A) It should display an alert dialog with text "2"
 (B) If in Step 5 I middle-clicked once, the tab should display onbeforeunload dialog
     If in step 5 I middle-clicked tab more than once, it should close.

Notes:
 1) In (A), Step 3: if I execute "setTimeout(_=>confirm(2),4000)" or even
     "setTimeout(_=>prompt(2),4000)", I still get the same result - the empty confirm dialog
 2) Not all "about:" pages are affected. The full list of affected "about:" pages:
> ["about:buildconfig", "about:cache", "about:home", "about:license", "about:logo", "about:mozilla", "about:rights", "about:robots", "about:sync-log"]
See Also: → 1235711
Depends on: 1233747
There's a patch for this in bug 1233747 (mozreview picked that bug instead of this one... the patch fixes both issues).
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1233747
arni2033@yandex.ru, could you please verify this issue is fixed as expected on a latest Nightly build (12/31/2015)? Thanks!
Flags: needinfo?(arni2033)
All 4 scenarios are now fixed on Nightly 46 (ID 20151231030214)
(note that expected result in cases B->C, B->D has changed due to bug 1234936)
Flags: needinfo?(arni2033)
Has STR: --- → yes
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.