60fps videos choppy due to 100% CPU usage

RESOLVED DUPLICATE of bug 1236112

Status

()

Core
Audio/Video: Playback
RESOLVED DUPLICATE of bug 1236112
3 years ago
2 years ago

People

(Reporter: Steve.hack, Unassigned)

Tracking

43 Branch
x86
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Linux; Android 6.0.1; Nexus 7 Build/MMB29K) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.83 Safari/537.36

Steps to reproduce:

Watch any 720p or 1080p video at 60fps on YouTube.


Actual results:

CPU shoots to 100% usage and the video becomes choppy.


Expected results:

CPU usage should be much lower and the video should be smooth. In comparison playing the same video in Edge results in 20 - 50% CPU usage and 100% smooth playback.

PS: The same issue affects GFycat as well at 60fps, but once again Edge runs them perfectly.
(Reporter)

Comment 1

3 years ago
I posted from my Nexus 7 but the issue is on my Yoga 2 10" Windows 10 tablet.
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86

Updated

3 years ago
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core

Updated

3 years ago
See Also: → bug 1236112
Steve, thanks for reporting this problem. On which Firefox version do you see 100% CPU usage? Is this a new problem?

Can you please copy/paste your Firefox Troubleshooting Information from about:support into this bug?

https://support.mozilla.org/en-US/kb/use-troubleshooting-information-page-fix-firefox
Can you also look at YouTube's stats for Nerds (available from right-click menu) and tell us the codec that is being used.
Flags: needinfo?(Steve.hack)

Comment 4

3 years ago
Same for me. It happened with version 42 but fixed in 43. Now the problem is back with version 44.

In about:support i see this:

(# 0) Error Too many dropped / corrupted frames, disabling DXVA

(# 1) Error Too many dropped / corrupted frames, disabling DXVA

Comment 5

3 years ago
(In reply to giovanninolol from comment #4)
> Same for me. It happened with version 42 but fixed in 43. Now the problem is
> back with version 44.
> 
> In about:support i see this:
> 
> (# 0) Error Too many dropped / corrupted frames, disabling DXVA
> 
> (# 1) Error Too many dropped / corrupted frames, disabling DXVA

p.s I have Windows 7 Pro
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(Steve.hack)
Resolution: --- → DUPLICATE
See Also: bug 1236112
Duplicate of bug: 1236112
You need to log in before you can comment on or make changes to this bug.