Disable crtdll.obj patch check for VS2015

RESOLVED FIXED in Firefox 47

Status

RESOLVED FIXED
3 years ago
8 months ago

People

(Reporter: poiru, Assigned: poiru)

Tracking

Trunk
mozilla47
Dependency tree / graph

Firefox Tracking Flags

(firefox46 affected, firefox47 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Created attachment 8703409 [details] [diff] [review]
Disable crtdll.obj patch check for VS2015

The crtdll.obj patch check fails when using VS2015 because its CRT .libs no longer contains crtdll.obj:

  LINK : fatal error LNK1146: no argument specified with option '/EXTRACT:'
  rm: cannot lstat `crtdll.obj': No such file or directory 

Firefox seems to run fine regardless so it seems like the CRT patch is no longer needed with the VS2015 runtime and the universal CRT.

For now, lets just skip the check on VS2015. After we switch to VS2015, we can rip out the CRT patch nastiness entirely.
Attachment #8703409 - Flags: review?(khuey)
(Assignee)

Updated

3 years ago
Assignee: nobody → birunthan
Status: NEW → ASSIGNED
Configure still succeeds without this patch, right?
Flags: needinfo?(birunthan)
(Assignee)

Comment 2

3 years ago
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #1)
> Configure still succeeds without this patch, right?

Yep (tested on Try as well).
Flags: needinfo?(birunthan)
(Assignee)

Comment 4

3 years ago
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #3)
> So then why take it?

Mostly to get rid of the two non-fatal messages printed out by configure. See comment 0 or the 'Failure summary' tab here: https://treeherder.mozilla.org/#/jobs?repo=try&revision=b9eaaa34d9c3&selectedJob=15032019

If the build fails for other reasons, those two messages will show up before the other errors. I suspect that will confuse people.
Comment on attachment 8703409 [details] [diff] [review]
Disable crtdll.obj patch check for VS2015

Review of attachment 8703409 [details] [diff] [review]:
-----------------------------------------------------------------

ok
Attachment #8703409 - Flags: review?(khuey) → review+
(Assignee)

Comment 6

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/b333f6ccccb170d3ff677eef2a702195d0fba554
Bug 1236330 - Get rid of configure warning spew on VS2015 from unnecessary crtdll.obj check. r=khuey

Comment 7

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b333f6ccccb1
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox47: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla47

Updated

2 years ago
Duplicate of this bug: 1069737

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.