server_test -d should enable debugging

RESOLVED FIXED in 4.12

Status

NSPR
NSPR
P2
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Guido Günther, Assigned: Guido Günther)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Created attachment 8703412 [details] [diff] [review]
0003-Unbreak-d.patch

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0 Iceweasel/38.5.0
Build ID: 20151216011944

Steps to reproduce:

run ./server_test -d


Actual results:

Test were run without debugging output


Expected results:

Debugging output should be printed.

The reason being an incorrect optparse tring in server_test.c. Patch attached.

Comment 1

2 years ago
Comment on attachment 8703412 [details] [diff] [review]
0003-Unbreak-d.patch

Review of attachment 8703412 [details] [diff] [review]:
-----------------------------------------------------------------

r=wtc. Thanks for the patch.

https://hg.mozilla.org/projects/nspr/rev/78f11a88dd11
Attachment #8703412 - Flags: review+
Attachment #8703412 - Flags: checked-in+

Updated

2 years ago
Assignee: wtc → agx
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
OS: Unspecified → All
Priority: -- → P2
Hardware: Unspecified → All
Resolution: --- → FIXED
Target Milestone: --- → 4.12
Version: 4.13 → other
You need to log in before you can comment on or make changes to this bug.