Closed Bug 1236892 Opened 4 years ago Closed 2 years ago

Enabling worker debugging disables Browser Content toolbox debugging

Categories

(DevTools :: Debugger, defect, P1)

46 Branch
All
Unspecified
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1250933

People

(Reporter: abdullah.diaa, Unassigned)

Details

(Keywords: dev-doc-needed)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20151230004007

Steps to reproduce:

Opened ToolBox Options and checked "Enable worker debugging (in development)" under Advanced settings.


Actual results:

Browser Content ToolBox debugging stopped working.


Expected results:

Browser Content ToolBox debugging should keep working while worker debugging enabled.
Component: Untriaged → Developer Tools: Debugger
Hardware: Unspecified → All
Thanks for reporting this bug!

Eddy, could you please have a look at this?
Flags: needinfo?(ejpbruel)
Summary: Enabling worker debugging disables Browser Content ToolBox debugging → Enabling worker debugging disables Browser Content toolbox debugging
(In reply to Jan Keromnes [:janx] from comment #1)
> Thanks for reporting this bug!
> 
> Eddy, could you please have a look at this?

Putting this on my todo list.
Assignee: nobody → ejpbruel
Flags: needinfo?(ejpbruel)
Priority: -- → P1
FWIW, this bug is probably a duplicate of Bug 1250933 which was fixed in Firefox 47.
Assignee: ejpbruel → nobody
Closing this as the option doesn't even exist anymore, and the bug might have also been fixed already as Julian mentioned.

Please reopen if you find this is not the case. Sorry about the delay!
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1250933
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.