The default bug view has changed. See this FAQ.

[form.mdn] Please add component drop-down to custom form

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
Extensions: Other
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: openjck, Assigned: dkl)

Tracking

Production

Details

(Reporter)

Description

a year ago
Users are dropped into a custom form [1] when submitting an MDN bug. The form has three sections: one for reporting a bug, one for requesting a new feature, and one for requesting a change to an existing feature.

Can we please add a component drop-down in each section above the summary field? That would help us triage reports a little more quickly. Thanks!

[1] https://bugzilla.mozilla.org/form.mdn
(Reporter)

Updated

a year ago
Duplicate of this bug: 1230619
(Assignee)

Updated

a year ago
Assignee: nobody → dkl
Status: NEW → ASSIGNED
(Assignee)

Comment 2

a year ago
I have made the change and would like you to give feedback and test the change. Once it's good we will get it ready to go to production.

https://bugzilla-dev.allizom.org/form.mdn

Thanks
dkl
Flags: needinfo?(jkarahalis)
(Reporter)

Comment 3

a year ago
John, can you review this before it goes live?
Flags: needinfo?(jkarahalis) → needinfo?(jwhitlock)
This is closer to what I wanted.  My workflow is:

1. Start a new bug at https://bugzilla.mozilla.org/enter_bug.cgi
2. Enter "browsercompat" in the search field to load the Mozilla Developer Network:BrowserCompat component
3. Select "Request a new feature" from the "Mozilla Developer Feedback" form, and "Next"
4. Fill out the form, submit

On the dev site, "BrowserCompat" isn't available (added after May 2015), so I chose:
1. Start a new bug at https://bugzilla-dev.allizom.org/enter_bug.cgi
2. Enter "dev net dash" to filter down to Mozilla Developer Network:Dashboards component
3. Enter "This is a Test" to search for other bugs
4. Wait and click "My issue is not listed"
5. Select "Request a new feature" from the "Mozilla Developer Network Feedback" form, and then "Next"
6. Re-select "Dashboard as my component.

This is an improvement, in that I can select the component, but it would be nicer if my component selection was remembered from the new bug form.

Also, I'd appreciate if searching for duplicate bugs was a skippable step, but that seems to be a dev-only feature test.
Flags: needinfo?(jwhitlock) → needinfo?(jkarahalis)
(Assignee)

Comment 5

a year ago
(In reply to John Whitlock [:jwhitlock] from comment #4)
> On the dev site, "BrowserCompat" isn't available (added after May 2015), so
> I chose:
> 1. Start a new bug at https://bugzilla-dev.allizom.org/enter_bug.cgi
> 2. Enter "dev net dash" to filter down to Mozilla Developer
> Network:Dashboards component
> 3. Enter "This is a Test" to search for other bugs
> 4. Wait and click "My issue is not listed"
> 5. Select "Request a new feature" from the "Mozilla Developer Network
> Feedback" form, and then "Next"
> 6. Re-select "Dashboard as my component.
> 
> This is an improvement, in that I can select the component, but it would be
> nicer if my component selection was remembered from the new bug form.
> 
> Also, I'd appreciate if searching for duplicate bugs was a skippable step,
> but that seems to be a dev-only feature test.

You are actually seeing the wrong form since the account you were using did not have the proper permissions. That form is the guided bug entry form and not the custom MDN form for which we are making changes.

I have emailed you credentials for jwhitlock@mozilla.com so please try again using that account.

dkl
Flags: needinfo?(jkarahalis) → needinfo?(jwhitlock)
With the Mozilla credentials:

1. Start a new bug at https://bugzilla-dev.allizom.org/enter_bug.cgi
2. Enter "browsercompat" to find the Mozilla Developer Network:BrowserCompat component
3. On Mozilla Developer Network Feedback, select "Request a New Feature" and "Next"
4. On bug entry, BrowserCompat is pre-selected :)
5. After filling out the form, the correct component is selected: https://bugzilla-dev.allizom.org/show_bug.cgi?id=1154177

Works for me!
Flags: needinfo?(jwhitlock)
(Assignee)

Comment 7

a year ago
To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   9391940..8687348  master -> master
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.